Neuerungen und Veränderungen in LibreOffice 4.2

From The Document Foundation Wiki
Jump to: navigation, search

Im Folgenden finden Sie eine Auflistung der Neuerungen und Veränderungen der Version 4.2 von LibreOffice. Dies ist eine Fortschreibung der vorangegangenen Neuerungen und Veränderungen der Version 4.1.

Writer

  • Verbesserter RTF-Import: Beginn der Unterstützung von gruppierten Formen für RTF (tdf#66040).
Miklos Vajna
Vorher.
Nachher.
  • Serien-E-Mails im HTML-Format mit Bildern: Die Einbindung von Bildern in HTML-Dateien ermöglicht nun das Versenden von Serien-E-Mails mit Bildern (tdf#63211).
Edmond Ciorba, Andras Timar
Vorher.
Nachher.
  • Neue Zeichenformatierung: Es ist nun möglich, eines oder mehrerer Zeichen mit einem Rahmen zu versehen (tdf#35155).
Tamás Zolnai
  • Unterstützte Dateiformate: ODT, HTML, DOC, DOCX, RTF.
  • Zu finden im Menü unter Format ▸ Zeichen... ▸ Umrandung.
Register Rahmen im Dialog Zeichen.
Rand um ein oder mehrere Zeichen.
  • Funktion Alles auswählen: Dies funktioniert jetzt auch in der speziellen Situation, wenn ein Textdokument mit einer Tabelle beginnt (tdf#37606).
Miklos Vajna
Geändertes Verhalten für Alles auswählen, wenn ein Dokument mit einer Tabelle beginnt.
  • Veränderung bei der Schnellsuche: Die Schnellsuche (Strg+F) wird jetzt nicht mehr von den Optionen im Dialog Suchen & Ersetzen (STRG+Alt+F) beeinflusst. Bisher wurden z. B. Suchbegriffe in der Schnellsuche, die reguläre Ausdrücke enthielten, nicht gefunden, wenn die Option Regulärer Ausdruck im Dialog Suchen & Ersetzen aktiviert war (tdf#62601).
Abdulmajeed Ahmed
  • Eingabefelder: Die direkte Bearbeitung von Eingabefeldern ist jetzt möglich.
Oliver-Rainer Wittmann
  • Verbesserte Funktionalität für Änderungen aufzeichnen: Das Kontextmenü umfasst nun für den schnelleren Zugriff Einträge zur Verfolgung von Änderungen (tdf#35746).
Miklos Vajna
Verfügbare Einträge: Änderung aktzeptieren, Änderung ablehnen, Nächste Änderung und Vorherige Änderung.
Neues Kontextmenü in Writer bei der Verwendung von Änderungen aufzeichnen.
  • Unterstützung für DOT: Writer kann nun auch im DOT-Format (MS-Word Vorlagen) speichern.
Miklos Vajna
Aufklappmenü im Dialog Speichern.
  • Verbesserung bei AutoKorrektur von Rahmen: Unterschiede sind jetzt offensichtlicher (tdf#71740).
Laurent Balland-Poirier
Vergleich von Rahmendicken.
  • Korrektur bei Querverweisen: Querverweise zu Überschriften, die Fußnoten beinhalten, enthalten jetzt auch in Kopfzeilen, Tipps und Dialogfeldern keine Fußnotennummern mehr (tdf#71645).
László Németh
Vorher.
Nachher.
Vorher.
Nachher.
  • Bessere Silbentrennung: Zwei Fehler, dass Wörtern mit harter Silbentrennung umgebrochen wurden sowie dass Wörtern mit abschließneden Satzzeichen nicht umgebrochen wurden, wurden behoben (tdf#56392).
László Németh
Vorher/Nachher.
  • Verbesserung bei Formatvorlagen: Bei Mehrfachauswahl von Vorlagen im Fenster Formatvorlagen ist nun auch das Löschen und Verstecken dieser möglich (tdf#67461).
Joren De Cuyper


Neue Dokumentvorlage

  • Neue Dokumentvorlage: Die Formatvorlagen der Standard-Dokumentvorlage für Writer wurden basierend auf den Rückmeldungen in Diskussionen angepasst.
Ahmad Harthi, Faisal M. Al-Otaibi
Aussehen der neuen Dokumentvorlage.

DOCX Verbesserungen

  • Verbesserungen für DOCX-Dokumente: Für den Import/Export aus/in DOCX-Dokumente(n) wurden diverse Verbesserungen vorgenommen:
Abdulmajeed ahmed, Jacobo Aragunde, Adam Co, Andrés Gómez, Faisal M. Al-Otaibi, Miklos Vajna
  • Writer behält die Einstellung für "Änderungen verfolgen" jetzt bei, wenn sie in einem DOCX-Dokument aktiviert ist (das Verfolgen von Änderungen selbst wird erst teilweise unterstützt) (tdf#64826).
  • Ganzseitige Hintergrundfarben werden nun richtig behandelt (tdf#65257).
  • Korrektur bei Abständen von Seitenumrandungen (tdf#64350).
  • Korrektur bei Dokumenten mit verschiedenen Inhalten für linke/rechte Kopf-/Fußzeilen (tdf#65655).
  • Korrektur bei versteckten Kopf-/Fußzeilen in DOCX-Dokumenten (tdf#64238).
  • Farben bei Unterstreichungen werden jetzt übernommen (tdf#65710).
  • Schattierung bei der Zeichenformatierung wird nun übernommen (tdf#65400).
  • Writer übernimmt jetzt auch Nummerierungen korrekt, die nicht bei 1 beginnen (tdf#66543, tdf#44689).
  • Korrektur bei Einzügen innerhalb von Textfeldern (tdf#66929).
Fortsetzung Verbesserungen:
  • Korrektur beim Export von Seitenumrandungen.
  • Korrekte Übernahme von unsichtbaren Aufzählungszeichen (Aufzählungszeichen der Ebene 0) (tdf#66781).
  • Korrektur bei Schatten von Seitenumrandungen in DOCX-Dokumenten (tdf#64350).
  • Umrandungen in Kopf-/Fußzeilen gehen jetzt nicht mehr verloren (tdf#67013).
  • Farbverläufe beim Hintergrund von Textfeldern werden nun korrekt übernommen (tdf#65295).
  • Drehinformation werden jetzt auch bei Bitmaps gespeichert (tdf#70457).
  • Positions- und Größenwerte von Formen werden jetzt richtig exportiert (tdf#70838).
  • Smart-Art Information werden jetzt beibehalten.
  • Die Ausrichtung und Schreibrichtung werden jetzt richtig importiert (tdf#43093).
  • Die Schreibrichtung wird jetzt richtig gespeichert, wenn das Dokument mit MS-Office erstellt wurde (tdf#71646).
  • Unterstützung für Schwebende Tabellen wurde hinzugefügt.
  • Es wurde der Fehler behoben, dass ein kaufmännisches &-Zeichen in Dokumenttiteln zu fehlerhaften DOCX-Dokumenten geführt hat (tdf#63053).

Calc

  • Neue Funktionen:
  • Die Funktionen WEBDIENST und XMLFILTERN zum Zugriff auf Internetdaten wurden hinzugefügt.
Markus Mohrhard
  • Die Funktionen LINKSB, LÄNGEB, TEILB und RECHTSB für binäre Zeichenfolgen wurden hinzugefügt.
Zhang Lu
  • Die statistischen Funktionen KOVARIANZ.B und KOVARIANZ.S wurden für die Kompatibilität zu MS-Excel hinzugefügt (tdf#70000).
Winfried Donkers
  • Die statistischen Funktionen STABW.N und STABW.S wurden für die Kompatibilität zu MS-Excel hinzugefügt (tdf#44134).
Winfried Donkers
  • Die statistischen Funktionen VAR.P und VAR.S wurden für die Kompatibilität zu MS-Excel hinzugefügt (tdf#61002).
Winfried Donkers
  • Die statistischen Funktionen BETA.VERT und BETA.INV wurden für die Kompatibilität zu MS-Excel hinzugefügt (tdf#71008).
Winfried Donkers
  • Die statistischen Funktionen BINOM.VERT und BINOM.INV wurden für die Kompatibilität zu MS-Excel hinzugefügt (tdf#71081).
Winfried Donkers
  • Die statistischen Funktionen KONFIDENZ.NORM und KONFIDENZ.T wurden für die Kompatibilität zu MS-Excel hinzugefügt (tdf#71350).
Winfried Donkers
  • Die statistischen Funktionen F.VERT, F.VERT.RE, F.INV, F.INV.RE und F.TEST wurden für die Kompatibilität zu MS-Excel hinzugefügt (tdf#71436).
Winfried Donkers
  • Die statistischen Funktionen EXPON.VERT, HYPGEOM.VERT, POISSON.VERT und WEIBULL.VERT wurden für die Kompatibilität zu MS-Excel hinzugefügt (tdf#71722).
Winfried Donkers
  • Verbesserte Funktion: Die statistische Funktion KRITBINOM wurde erheblich verbessert, um auch mit großen Probenmengen umgehen zu können.
Winfried Donkers
  • Einschränkung bei Einzügen: Ein vergrößerter Einzug kann jetzt nicht mehr über die Zelle hinausgehen.
Abdulmajeed ahmed
  • Neues Kontextmenü: Beim Rechtsklick auf die Schaltflächen zum Rollen der Tabellenblätter wird jetzt ein Kontextmenü angezeigt, das den Wechsel des aktiven Tabellenblatts ermöglicht.
Caolán McNamara
Neues Kontextmenü
  • Verbesserte Formelanpassung: Der Zellbezug einer Formel kann jetzt durch Ziehen aller vier Ecken verändert werden (tdf#67592).
Tomaž Vajngerl
Verbesserte Formelanpassung
  • Neuer Zufallszahlgenerator: Zufallszahlen lassen sich jetzt komfortabel mit dem neuen Dialog Zufallszahl generieren (tdf#66477).
Zu finden im Menü unter Bearbeiten ▸ Ausfüllen ▸ Zufallszahl....
Tomaž Vajngerl
Zufallszahlengenerator.
  • Neue Statistikfunktionen: Unterhalb des neu geschaffenen Menüeintrags Daten ▸ Statistik finden sich neue Dialoge für Statistikfunktionen (vergleichbar mit Excels "Analysefunktionen") (tdf#66477).
Tomaž Vajngerl
  • Stichproben
  • beschreibende Statistik
  • Analyse von Varianzen
  • Korrelationen
  • Kovarianzen
  • Exponentielles Glätten
  • Gleitender Mittelwert
  • Verbesserung bei der Suche: Die Schaltfläche Suche alle im Dialog Suchen & Ersetzen ist nun auch bei aktivierter Option In allen Tabellen suchen anklickbar. Hierfür wurde ein neuer Dialog geschaffen, der die betroffenen Zellen nun auflistet (tdf#39881).
Matúš Kukan
Suche alle: Suchergebnisse.
  • Schnellere Formel-Berechnung: Es wurde ein neuer Formel-Interpreter implementiert, der parallele Berechnungen unter Verwendung der GPU mittels OpenCL erlaubt.
Kohei Yoshida, Tor Lillqvist, Michael Meeks, Markus Mohrhard - AMD, MultiCoreWare
Neue Option „OpenCL aktivieren“ im Dialog Detaillierte Einstellungen für Berechnungen

Diagramme

  • Verbesserter XLSX-Import: Import von Diagrammen aus XLSX, die keine ordnungsgemäßen Bezüge aber eingebettete Daten haben.
Muthu Subramanian
  • Einfachere Einstellung der Gitterlinien: Es wurde eine neue Schaltfläche der Symbolleiste hinzugefügt, um auch das vertikale Gitter ein- und auszuschalten. Außerdem wurde das Verhalten sowohl für das vertikale als auch für das horizontale Gitter so geändert, dass zwischen "Hauptgitter", "Haupt- und Hilfsgitter" bzw. "Kein Gitter" umgeschaltet werden tdf#66422.
Tomaž Vajngerl
  • Erweiterung von Trendlinien:
Tomaž Vajngerl
  • Es werden jetzt auch mehrere Trendlinien (verschiedene Arten) für jede Datenreihe unterstützt.
  • Polynomiale (vielgliedrige) Trendlinien wurden neu hinzugefügt tdf#35712.
  • Festlegung des Bereichs, der für polynomialen Trendlinien berücksichtigt wird tdf#40315.
  • Der Durchgang durch den Ursprung (bzw. durch einen anderen Y-Wert) kann für Trendlinien jetzt erzwungen werden tdf#40314.
  • Die Darstellung von Trendlinien erfolgt jetzt standardmäßig nur noch im Datenbereich. Die Weite der Fortsetzung von Trendlinie kann aber für beide Richtungen nun separat eingestellt werden tdf#40316.
Verbesserungen bei Trendlinien: Mehrere Trendlinien sowie...
oben links: erzwungener Nulldurchgang
oben rechts: Fortsetzung von Trendlinien
unten links: polynomiale Trendlinien
unten rechts: Festlegung des Bereichs

Impress

  • verbesserte Ansicht "Foliensortierung": In der Foliensortierung weisen nun Symbole auf Folienübergänge und Animationen hin tdf#65456.
Edmond Ciorba, Andras Timar
Symbole, die auf Folienübergänge und Animationen hinweisen.
  • Neue Fernsteuerung für iOS: Die Fernsteuerung für Präsentationen steht nun auch für iOS zur Verfügung.
  • Geänderte Voreinstellung: Die Seitenleiste ist nun (nur für Impress) standardmäßig aktiviert.
  • Benutzerdefinierte Animation: Das Fenster wurde neu überarbeitet tdf#62082.
Samuel Mehrbrodt
Neuer Bereich Benutzerdefinierte Animation
  • Verbesserung an der Presenter Console: Auch hier weisen Symbole auf Folienübergänge und Animationen hin. Dadurch ist eine einfachere Präsentation des gesamten Inhalts einer Folie möglich tdf#65457.
Edmond Ciorba, Andras Timar
Vorschau.
Notizen.
Sortiertisch.

Base

  • Neues Feature: Die Art der Speicherung von Referenzwerten bei Markierfeldern kann nun eingestellt werden. Dies erlaubt, das alte Verhalten (Schreiben von "1" und "0") wiederherzustellen. Es erlaubt aber z. B. auch, das Verhalten von (an binäre Felder gebundenen) Markierfeldern umzukehren, indem die Markierfeld-Eigenschaften mit "Referenz (an): falsch" und "Referenz (aus): wahr" gesetzt werden.
Lionel Elie Mamane
  • Anbindung an Firebird SQL-Datenbank hinzugefügt: Mehr dazu im Abschnitt "Experimentelle Features".
  • Änderung aufgrund einer Inkompatibilität: Ein an ein Zeichenfolgen-Feld gebundenes Markierfeld liefert nun "wahr" oder "falsch" als Werte, wo LibreOffice 4.1 noch "1" oder "0" notiert hat. Beim Öffnen älterer Datenbanken werden die Werte "1" und "0" aber korrekt importiert.
Lionel Elie Mamane

Math

  • Maßstab: Auch in Math lässt sich die Ansicht jetzt mittels Maßstab vergrößern und verkleinern tdf#63351.
Thomas Arnhold
  • Neu Komfortfunktion: Klammern werden jetzt (nur bei der Eingabe am Zeilenende) automatisch geschlossen tdf#43090.
Marcos Paulo de Souza
  • Schnellzugriff auf Farben: In die Seitenleiste wurden die möglichen Farben integriert und sind jetzt mittels Klick auf ihren Namen verfügbar.
Marcos Paulo de Souza
Farben in der Seitenleiste von Math.

Installer (nur Windows)

  • Installationsauswahl einzelner Module entfernt: Bei der benutzerdefinierten Installation wurde die Auswahlmöglichkeit zur Installation einzelner Module entfernt. Diese Auswahlmöglichkeit war nur im geringen Maße sinnvoll, da alle Module im Programm enthalten sind und immer mit installiert werden. Es wurden lediglich die Startmenü-Icons und Kurztasten unterdrückt. Diese Auswahlmöglichkeit war eine Quelle vieler Bugs.
Andras Timar
Vorher.
Nachher.

Kern

  • Verbesserte PDF-Unterstützung: Verbesserung der Handhabung von PDF in LibreOffice durch Upgrade von XPDF auf Poppler tdf#38878.
Peter Foley, Tor Lillqvist, Fridrich Štrba
  • Option zum Blockieren externer Links: Eine neue Option "Jeden Link aus Dokumenten blockieren, der nicht als vertrauenswürdige Quelle gilt (vgl. Makrosicherheit)" wurde im Dialog Extras ▸ Optionen... ▸ LibreOffice ▸ Sicherheit ▸ Sicherheitsoptionen und -warnungen hinzugefügt, um einen automatischen Zugriff auf externe Referenzen zu unterbinden rhbz#887420.
Stephan Bergmann
  • Diese Funktion ist noch nicht vollständig umgesetzt.

Einstellungen / Allgemeines

Windows-Registry Änderungen

  • LibreOffice benutzt nun unter Windows die 'Group Policy', sodass Administratoren bestimmte Konfigurationen und Einstellungen voreinstellen bzw. sperren können. Für genauere Informationen siehe die englische Seite. Dies wurde von der ungarischen E-Governmental Free Software Competence Centre (E-Governance Freie Software Kompetenzzentrum) entwickelt.

Code-Qualität

  • Verbesserung der Code-Qualität: Die Code-Qualität von LibreOffice wurde basierend auf dem Coverty Analysescan von Version 4.1 zu 4.2 z. T. deutlich verbessert.
Stephan Bergmann, Herbert Dürr, Jan Holesovsky, Andrzej J.R. Hunt, Marc-André Laverdière, Caolán McNamara, Markus Mohrhard, Julien Nabet, Noel Power, Michael Stahl, Norbert Thiebaud, Miklos Vajna
Ergebnisse des Coverty Analysescans.

Filter

  • Agile Entschlüsselung: Unterstützung für die Entschlüsselung von Dateien, die mit der Standardverschlüsselung von MS Office 2010 und 2013 verschüsselt wurden tdf#35422. :: Tomaž Vajngerl
  • OOXML-Verschlüsselung: Die OOXML-Verschlüsselung wird jetzt unterstützt tdf#59524.
Tomaž Vajngerl
  • OOXML-Beschleunigung: Alle OOXML-Prozesse wurden erheblich beschleunigt, indem diese in separate Bibliotheken ausgelagert wurden, sowie weitere Optimierungen bei der Verarbeitung vorgenommen wurden.
Matus Kukan, Michael Meeks
  • MathML-Export: Der MathML-Export wurde verbessert.
Frédéric Wang
  • PDF-Export: Beim PDF-Export werden jetzt 14 Standard Postscript-Schriftarten immer mit eingebettet.
Khaled Hosny
  • Apple Keynote: Ein Importfilter für Apple Keynote-Dateien wurde hinzugefügt.
David Tardon
Apple Keynote-Importfilter
  • Weitere MAC-Dokumenttypen: Der Import weiterer MAC-Dokumenttypen wird nun unterstützt.
Laurent Alonso, David Tardon
  • Acta Mac Classic-Dokument
  • Beagle Works / WordPerfect Works-Dokument
  • Great Works-Dokument
  • MacDoc-Dokument
  • More Mac-Dokument (v2-3)
  • WordPerfect Works-Document
  • Verbesserungen für OOOXML: Es wurden zahlreiche Verbesserungen für Microsoft Import- und Exportfilter vorgenommen. Dies betrifft die Dateiformate:
  • OOX, DOCX, XLSX, PPTX und VML
  • DOC, XLS, PPT
  • RTF
  • PDF-Lesezeichen: PDF-Lesezeichen beinhalten keine Fußnotennummerierung tdf#71645.
László Németh
Vorher.
Nachher.
  • E-Book-Dateiformate: Es wurden Importfilter für verschiedene E-Bookformate implementiert, die meisten Palm-basiert.
David Tardon
  • FictionBook 2
  • PalmDoc
  • PeanutPress (eReader)
  • Plucker
  • TealDoc
  • zTXT

GUI

  • Neuer Startbildschirm: Ein neuer Startbildschirm wurde kreiert.
Krisztian Pinter, Mirek Mazel, Stefan Knorr, Krzysztof Ponikiewski, Rodolfo Ribeiro Gomes, Tamas Zolnai, Jan Holesovsky
Neuer Startbildschirm
  • GNOME 3: Für GNOME 3 existiert jetzt eine Integration in das Menü "Anwendungen" tdf#48835.
Caolán McNamara
GNOME 3 Integration
  • Bessere Aufteilung bei mehrzeiligen Registern: Wenn Register zwei oder mehr Zeilen brauchen, um dargestellt werden zu können, werden sie nun vorteilhafter aufgeteilt, sodass kein Register mehr alleine in einer Zeile steht tdf#66435.
Stefano Facchini and Caolán McNamara
Vorher.
Nachher.
  • Suchleiste: Die Schaltfläche "Alle finden" wurde zur Suchleiste hinzugefügt tdf#64451.
Andrzej J.R. Hunt
  • Gruppierte Fenster: Unter Windows 7 und höher werden die Fenster jetzt nach Anwendungen sortiert gruppiert, sodass alle Writer-/Calc-/...-Fenster eine eigenen Gruppe darstellen.
Jesús Corrius
Gruppierte Fenster.
  • Zuletzt verwendete Dokumente: Unter Windows 7 und höher werden im Kontextmenü des Taskleisten-Symbols jetzt die zuletzt verwendeten Dokumente mit aufgelistet.
Jesús Corrius and Fridrich Štrba
Kontextmenü der Taskleiste.
  • Öffnen mit...: Unter Windows wurde die Liste der unterstützen Dokumenttypen, für die im Kontextmenü unter Öffnen mit ▸ LibreOffice angezeigt wird, erweitert.
Jesús Corrius
  • Desktop-Unterstützung: Die Integration (Dialoge Öffnen/Speichern) in die Desktopumgebungen MATE und XFCE werden jetzt zusätzlich unterstützt tdf#46990.
Pader Rezso
  • Lineale: Beim Verschieben von Markern in den Linealen werden diese nun an Linealunterteilungen gefangen. Außerdem werden bei den Zahlen in den Liniealen nun die Markierungen ober- und unterhalb der Zahl angezeigt (zuvor waren diese wegen der Zahlen an der entsprechenden Position weggelassen worden). Und Tooltipps zeigen nun die exakte Position von Markern an.
Tomaž Vajngerl
Verbessertes Lineal.
  • about:config-Funktionalität: In den Optionen wurde ein neues Register "Experteneinstellungen" mit einer about:config-Funktionalität integriert. Dies kann durch Setzen des Wertes EnableExpertConfiguration auf false in der Benutzerkonfiguration wieder ausgeschalten werden.
Efe Gürkan YALAMAN
Experteneinstellungen in den Optionen.
  • GoogleDrive: Es ist nun möglich, direkt auf Dokumente im GoogleDrive zuzugreifen, indem im Dialog Eigenschaften die CMIS-Einstellungen angepasst werden
Cuong Cao Ngo
  • Seitenleiste erweitert: Zur Seitenleiste wurden Schaltflächen für RTL und LTR hinzugefügt tdf#67746.
Abdulmajeed ahmed
  • Korrektur der Barrierefreiheit: Die Anforderungen an die Barrierefreiheit wurden korrigiert, sodass Benutzer mit dunklen Themen wieder die Verwendung von festgelegten Farben ermöglicht wird tdf#71511.
Bjoern Michaelsen
  • Neuer Iconsatz Sifr: Ein neuer Iconsatz mit Namen Sifr wurde in LibreOffice 4.2 integriert. Dieser hilt durch sein schlichtes Design, den Benutzer weniger vom Dokument abzulenken.
Issa Alkurtas, Norah Abanumay, Mirek M., Pavel Haratický and Ahmad Harthi
Writer mit Sifr-Symbolen
  • Objekt Smiley: Der Smiley lacht jetzt richtig.:
Ahmad Harthi
Der Smiley vorher und nachher.

Lokalisierung

  • Neue Sprachen: Es wurden mehrere Sprachen in die Sprachliste oder zur Benutzeroberfläche hinzugefügt.
Eike Rathke, Domingo Sacristan, David Delma, JJ Méric, Michael Bauer


Sprachwerkzeuge

  • Aktualisierung deutscher Wörterbücher: Stark verbesserte deutsche Sprachwerkzeuge (de-AT, de-CH, de-DE) mit mehr als 10.000 neuen Wörtern in der deutschen Rechtschreibprüfung und aktualisierter Silbentrennung. Zum ersten Mal umfasst der deutsche Thesaurus (Synonymwörterbuch) über 100.000 Wörter in über 28.000 Bedeutungsgruppen.
  • Weitere Wörterbücher: Es wurden für mehrere Sprachen die Wörterbücher erneuert.

Einführung des Euro

  • Änderung der lettischen Währung: Lettland hat am 01.01.2014 den Euro angenommen, davon abhängige Änderungen tdf#73239.
Eike Rathke
  • 'EUR'-Währung bei den lokalen [lv-LV]- und [ltg-LV]-Einstellungen ergänzt und als Währungsvorgabe eingestellt.
  • Die lettischen Lats 'LVL' zum Euro-Koverter hinzugefügt: Datei ▸ Assistenten ▸ Euro-Konverter....
  • Umwandlungsfaktor für Lats "LVL" (0,702804) der Tabellenkalkulationsfunktion EUROUMRECHNEN() hinzugefügt.
  • Ergänzung für estnische Kronen: Umwandlungsfaktor für Estnische Krone "EEK" (15,6466) der Tabellenkalkulationsfunktion EUROUMRECHNEN() hinzugefügt.

Experimentelle Features

  • Anbindung an Firebird SQL-Datenbank hinzugefügt: Wählen Sie bei der Erstellung einer neuen Datenbank "Eingebettetes Firebird" aus dem Aufklappmenü "Eingebettete Datenbank" aus (Hierzu müssen die Experimentellen Funktionen in Extras ▸ Optionen ▸ LibreOffice ▸ Erweitert aktiviert sein). Dadurch erhalten Sie eine Datenbank, die um ein Vielfaches schneller als die zuvor eingebettete HSQL-Datenbank ist. Der Plan ist, in einer späteren Veröffentlichung eine einfache Migrationsmöglichkeit zu Firebird zu schaffen.
Andrzej Hunt
Ein paar Worte zu Firebird: Die Integration von Firebird in Libreoffice Base ist ein großer Schritt in die Zukunft. Firebird ist eine ausgereifte, relationale SQL-Datenbank, die ACID-kompatibel ist und eine plattformübergreifende Unterstützung, Multi Generation Architecture, referentielle Integrität und Fähigkeiten wie Protokollierung und Überwachung bietet. Sie bietet zudem eine hohe Leistung, exzellente Parallelität und eine mächtige Sprachunterstützung für gespeicherte Prozeduren, Trigger und mehr. Es findet in Produktionssystemen unter einer Vielzahl von verschiedenen Namen seit 1981 Verwendung.
Datenbankauswahl.
  • JAB zu IA2: Für windows wurde eine neue, experimentelle Accessibility-Bridge, IAccessible2 (IA2), hinzugefügt, basierend auf Code von IBM. Standardmäßig wird noch die bisherige Java Access Bridge (JAB) verwendet, aber mit der Aktivierung der Experimentellen Funktionen unter Extras ▸ Optionen... ▸ LibreOffice ▸ Erweitert wird zur IA2 gewechselt. Bitte stellen Sie sicher, dass Ihr Accessibility-Tool IA2 unterstützt, bevor sie es ausprobieren; Für NVDA ist bekannt, dass es funktioniert.
  • Datenströme empfangen: Eine experimentelle Funktion zum empfangen von Datenströmen wurde hinzugefügt, zu finden im Menü Daten ▸ Stream.... Diese Funktion ist noch hoch-experimentell und standardmäßig deaktiviert. Sie müssen im Menü Extras ▸ Optionen... ▸ LibreOffice ▸ Erweitert die Option Experimentelle Funktionen aktivieren auswählen, um diese Funktion ausprobieren zu können.
Matúš Kukan, Kohei Yoshida
Dialog Live-Datenströme

Leistung

  • Verbesserung der Leistung in Calc:
  • Calcs Speicherstruktur für Zellen wurde komplett neu geschrieben, um zusammenhängende Zellwerte in beieinanderleigenden Speicherregionen abzulegen. Dadurch konnte die Referenzlokalität sowie der Speicherverbrauch verbessert werden. Die neue Struktur erlaubt zudem hardware-beschleunigte parallele Berechnungen bei einer hohen Zahl von Zellen.
Kohei Yoshida
  • Der Kern von Calc teilt nun alle Zeichenfolgen-Instanzen, die in Zellen oder an anderen Orten abgelegt sind, auf und kann damit erhebliche Geschwindigkeitszuwächse bei Vergleichen von Zeichenfolgen – egal ob mit oder ohne Berücksichtigung der Groß- und Kleinschreibung – erzielen und ermöglicht somit Gleichheitsprüfungen über OpenCL-basierte Formel-Interpreter. Diese Änderung beschleunigt diverse Zellfunktionen (z. B. SVERWEIS), bei denen eine hohe Anzahl an Gleichheitsprüfungen durchgeführt werden müssen. Auch das Filtern durch AutoFilter, Standardfilter und Spezialfilter wird dank Zeichenfolgen-Aufteilung nun schneller erledigt.
Kohei Yoshida
  • Vertikal benachbarte Formelzellen, die einen identischen Formelzeichensatz enthalten, teilen sich nun ihre Formelzeichen-Matrixinstanzen. Dies kann zu deutlich kürzeren Speicherbelegungen während der Berechnungen in Calc führen und die automatische Referenzaktualisierung beim Verschieben von Zellen beschleunigen.
Kohei Yoshida
  • Die Geschwindigkeit bei der Verwendung von SVERWEIS mit externen Referenzen konnte erhöht werden.
Pierre-Eric Pelloux-Prayer
Fortsetzung Verbesserung:
  • Die Geschwindigkeit bei der Berechnung von SUMME, ZÄHLEN und SUMMENWENNS konnte gesteigert werden.
Kohei Yoshida
  • Die XLSX-Importfilter wurden überarbeitet, um eine Steigerung der Leistung beim Import von XLSX-Dokumenten zu erzielen. Der Leistungszuwachs wurde durch Verlagerung der temporären Zeichenfolgen-Zuweisung und -Freigabe, welche während der XML-Analysephase auftritt, in einen separaten Prozess erreicht sowie durch Überarbeitung der Handler-Logik auf Seiten von Calc, um die Effizienz, insbesondere beim Import von Formelzellen, zu erhöhen.
Kohei Yoshida, Michael Meeks, Matúš Kukan
  • Ein experimenteller Multithreaded-Import für XLSX-Dokumente wurde hinzugefügt. Wenn die Option Experimentelle Funktionen aktivieren im Menü Extras ▸ Optionen... ▸ LibreOffice ▸ Erweitert eingeschaltet ist, versucht Calc, mehrere Tabellenblätter parallel zu importieren. (Kohei Yoshida, Michael Meeks)
  • Eine deutliche Beschleunigung konnte beim Export in ODS-Dokumente, welche eine hohe Anzahl an echt-Text-Zellen (Zellen mit Zeichenformatierungen oder mehrzeilige Textzellen) enthalten, erzielt werden.
Kohei Yoshida
  • Der Speicher für Zell-Kommentare wurde überarbeitet, sodass der Import und Export von Dokumenten, die eine große Anzahl an Kommentaren enthalten, jetzt schneller abläuft.
Laurent Godard

Infrastruktur

  • 64-bit Builds für OS X: 64-bit-Builds wurden für OS X ergänzt.
  • Neue API: Neue experimentelle Liblibreoffice API, die (zunächst) Filtern von LibreOffice erlaubt, durch die direkte Anbindung an den Libreoffice-Kern, wieder verwendet werden zu können. Diese hat eine einfache C- und C++-Wrapper-API und bringt keine Laufzeitabhängigkeiten mit sich (über eine sehr kleine statische Bibliothek / Shim).
Michael Meeks
  • Rückverfolgung von Fehlern unter Windows: Es wurden ein Symbol- und ein Quellserver für LibreOffice unter Windows hinzugefügt:
Fridrich Štrba, Luboš Luňák, Jan Holešovský, Christian Lohmaier
  • Wenn ein Fehler in Windows festgestellt wird, ist es nun sehr einfach, eine Rückverfolgung oder weitere Informationen über den Symbolserver und den Quellserver zu erhalten.
  • Weitere Informationen zur Verwendung (englisch).

Skriptsprachen/Base

  • Neue API: LibreOffice liegt jetzt Access2Base bei, eine vereinfachte API für das Scripting in Base (und Writer-Datenbank-Formularen) in der Programmiersprache Basic. Es ist übersichtlicher und leichter zu lernen als die Standard-Sprache UNO API.

ODF Änderungen

  • OFD-Korrektur: Ein Tippfehler im ODF-Dateiformat bei Verwendung einer der türkisen Tabellenvorlagen in Impress wurde korrigiert. Für Dateien, die diese Vorlage verwenden, existiert für die Fehlerbehebung ein HowTo (englisch).