LibreOffice 6.3: Release Notes

From The Document Foundation Wiki
Jump to: navigation, search
This page is a translated version of the page ReleaseNotes/6.3 and the translation is 64% complete.

Other languages:
dansk • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎日本語 • ‎português do Brasil • ‎русский • ‎slovenščina • ‎中文(中国大陆)‎


Contents

Об этой странице

Writer

  • The "Words With TWo INitial CApitals" AutoCorrect exception list function has been extended to also be considered when changing case in "Capitalize first letter of every sentence" and "Correct accidental use of cAPS lOCK key" functions. This allows avoid auto-capitalization in words like mRNA, iPhone, fMRI. It has been renamed to "Words With TWo INitial CApitals or sMALL iNITIAL" tdf#121779 (Mike Kaganski - Collabora).
  • Добавлена UNO команда .uno:TableCellBackgroundColor чтобы позволить устанавливать цвет фона для одной или нескольких выделенных ячеек таблицы tdf#82504 (Jim Raykowski)
  • В контекстное меню Навигатора был добавлен пункт "Отправить структуру в буфер обмена(щёлкните правой кнопкой мыши по строке "Заголовки") tdf#123395 (Wenzhe Pei).
  • Поле для ввода переменной Вставка ▸ Поле ▸ Ещё поля... ▸ Переменные ▸ Input field может быть отредактировано напрямую, in the same way as was already possible for function input fields Insert ▸ Field ▸ More Fields... ▸ Functions ▸ Input field tdf#123968 (Michael Stahl, CIB)
  • Обновление Индекса/Оглавления теперь можно отменять/возвращать и теперь обновление теперь не очищает список действий для отмены tdf#38703 (Michael Stahl, CIB)
  • Улучшено копирование таблиц из Calc в существующие таблицы Writer: копируются и вставляются только видимые в Calc ячейки tdf#124646 (László Németh, NISZ)
Only filtered rows of the Calc data are copied to Writer tables
  • Фон страницы теперь покрывает весь лист, а не как ранее только внутри границ текста tdf#33041 (László Németh, NISZ)
Colored pages without white margins
  • Улучшена совместимость с Word в поддержке направления написания сверху-вниз и слева-направо в ячейках таблиц и текстовых врезках статья в блоге 1 статья в блоге 2 (Miklos Vajna, Collabora)
New btLr text direction in Writer
Import of Microsoft drawingML group shapes in Writer

Interoperable text-based form controls

LibreOffice уже достаточно неплохо импортировал формы Microsoft Word - с годами многое улучшилось - и из LibreOffice 6.3 также можно добавлять элементы управления формами Word. После включения опции Сервис ▸ Параметры ▸ Writer ▸ Совместимость ▸ Меню Формы, совместимое с MS, меню Формы в Writer изменяется.

Microsoft compatible forms menu in Writer
  • Опциональное меню Форма, аналогичный MS Office (Tamás Zolnai, Collabora)
  • Реализация интерфейса для устаревших элементов управления (Tamás Zolnai, Collabora)

Есть много интересного, что можно узнать об этом улучшении форм, на странице Form controls in LibreOffice

Производительность при открытии/сохранении файлов

  • Улучшена производительность при сохранении файла с закладками. Время сохранения файла стало в 1,5 раза меньше tdf#117066 (Noel Grandin, Collabora)
  • Улучшена производительность при наличии больших таблиц. tdf#84635 (Noel Grandin, Collabora)
  • Улучшена производительность при наличии встроенных в документ шрифтов. tdf#69060 (Mike Kaganski, Collabora)
  • Улучшена производительность для некоторых специфичных ODT файлов tdf#63640 (Noel Grandin, Collabora)
Better performance of various file openings in Writer
  • Полный список исправлений производительности в Writer в этой версии смотрите здесь

Calc

  • Добавлено UNO API для изменения размера изображения, привязанного к ячейке (Samuel Mehrbrodt, CIB) tdf#124329
  • Добавлен новый формат для валюты Рубль РФ. Будет отображаться знак (U+20BD) вместо руб. (Eike Rathke, Red Hat) tdf#96711
  • Добавлен новый выпадающий виджет с функциями в строку для ввода формул вместо кнопки Сумма (Gagandeep Singh) tdf#120697
Новый выпадающий виджет в панели ввода формул
  • Теперь пользователь может отключить дополнительный диалог с результатами поиска. Для включения этого диалога используйте опцию Show summary of replaced cells в диалоге Сервис ▸ Параметры ▸ Calc ▸ Общие ▸ Input Settings tdf#87965 (Heiko Tietze)
Результаты поиска
  • Добавлен новый флажок в диалоге Данные ▸ Статистика ▸ Скользящее среднее который позволяет обрезать диапазон ввода до фактически содержащихся данных перед вычислением скользящего среднего. Этот флажок включен по умолчанию. Также исправлены проблемы производительности даже для случая, когда флажок выключен (Dennis Francis, Collabora) tdf#99938.
Диалог Скользящее среднее с новым флажком.
  • Окно автофильтра теперь не мерцает в Windows без OpenGL tdf#101086 (Miklos Vajna, Collabora)

Переработан диалог Данные -> Статистика -> Выборка

Вся работа была проделана Eike Rathke commit

  • Добавлен чекбокс "С заменой"
    • выбран: возможен больший размер выборки, чем размер популяции
      • взаимоисключающий с "Сохранять порядок"
    • не выбран: размер выборки ограничен размером популяции
      • автоматически отключается для варианта "Периодически"
  • Добавлена опция "Сохранять порядок"
    • выбрана: выборки составляются в порядке данных
      • WOR method mutually exclusive with "With replacement"
      • automatically checked for "Periodic" samples
    • unchecked: samples are drawn in random order
Moving Average dialog with the new "trim input range" checkbox.
  • Limit “Sample size” and “Period” input fields to size of population for all WOR methods
    • when limiting, increment “Sample size” and “Period” up to their last known value when enlarging the population size

Previously, for “Periodic” samples the “Period” field was never limited, which for populations of smaller size makes no sense.

The new recent implementation for “Random” without “Keep order” and without “With replacement” set (WOR) strictly needs “Sample size” limited to population size.


Новые функции электронных таблиц

Функция FOURIER()

FOURIER(Array, GroupedByColumns, Inverse, Polar, MinimumMagnitude) - это матричная функция, которая вычисляет дискретное преобразование Фурье для введённого массива (первый аргумент), используя пару быстрых алгоритмов преобразования Фурье. Все возможности этой функции также доступны через диалог Данные ▸ Статистика ▸ Анализ Фурье tdf#74664 блог (Dennis Francis, Collabora)

Данные в массиве (первый аргумент) могут быть:

  • сгруппированы по столбцам (должен быть установлен флажок GroupedByColumns = TRUE). В этом случае массив может содержать 1 или 2 столбца, где первый столбец содержит действительную часть входящей последовательности и второй столбец, если есть, содержит мнимую часть входящей последовательности. Если есть только один столбец, то входная последовательность рассматривается как чисто реальная.
  • сгруппированы по строкам (должен быть установлен флажок GroupedByColumns = FALSE). В этом случае массив может содеражть 1 или 2 строки, где первая строка содержит действительную часть входящей последовательности и вторая строка, если есть, содержит мнимую часть входящей последовательности. Если есть только одна строка, то входная последовательность рассматривается как чисто реальная.

Третий аргумент "Inverse" - это логический флаг, который показывает, нужно ли вычислять обратное дискретное преобразование Фурье. Этот аргумент опциональный и по-умолчанию установлен в FALSE.

Четвёртый аргумент "Polar" - это логический флаг, указывающий, должен ли результат быть в полярных координатах. Этот аргумент опциональный и по-умолчанию установлен в FALSE.

Результат дискретного преобразования Фурье состоит из двух столбцов - первый столбец содержит действительные части (или магнитуды, если Polar = TRUE), а второй столбец содержит мнимые части (или фазы, если Polar = TRUE).

Также есть пятый опциональный параметр - MinimumMagnitude. Этот параметр использует только, если четвертый аргумент Polar = TRUE. Все частотные составляющие с величиной меньше, чем MinimumMagnitude, будут подавлены с нулевым значением фазы магнитуды. Это очень полезно при взгляде на амплитудно-фазовый спектр сигнала, поскольку при выполнении быстрых алгоритмов преобразования Фурье всегда имеется очень небольшая ошибка округления, что приводит к неправильной ненулевой фазе для несуществующих частот. Предоставляя подходящее значение для этого параметра, эти несуществующие частотные компоненты могут быть подавлены. По умолчанию значение этого 5-го параметра равно 0.0, поэтому подавление не выполняется по умолчанию.

Fourier Analysis Tool in action

Производительность

  • Ускорена загрузка XLSX файлов. tdf#67629 tdf#85522 tdf#121094 (Noel Grandin, Collabora)
  • Ускорена загрузка ODS. tdf#120445 tdf#85482 (Noel Grandin, Collabora)
  • Ускорена загрузка и отрисовка файлов, содержащих функцию ВПР, в Calc (Serge Krot, CIB / Eike Rathke, Red Hat) tdf#121052
  • Ускорено сохранение файлов в формат XLS. tdf#85470 (Noel Grandin, Collabora)
  • Кэширование позиций MDDS для повышения производительности при работе с большими наборами данных tdf#112383 (Luboš Luňák, Collabora)
Improved performance in Calc
  • Полный список исправленных в этой версии проблем производительности в Calc смотрите здесь

Изменения функций электронных таблиц

Impress & Draw

  • Теперь можно перетаскивать несколько эффектов анимаций за раз для изменения их порядка. (Brian Fraser) патч
  • Добавлена экспертная настройка 'WriteLayerStateAsConfigItem' со значением по умолчанию 'true'. Если вы установите её в 'false', состояние слоёв Видимый / Печатаемый / Заблокированный записываются только в ODF-формате, в соответствующей части styles.xml, в противном случае - дополнительно в settings.xml. Вам может потребоваться опция 'false', чтобы избежать несогласованности в случае, если вы манипулируете слоями с помощью макроса. (Regina Henschel) commit
  • OOXML preset shapes as used by PowerPoint or SoftMaker had some glitches in handle-movement, when you tried to alter the shapes in LibreOffice. The shape outline moved in opposite direction of the handle movement, or the handle jumped to a new location, when you touched it, or the handle was not movable at all. That is fixed for most shapes now.(Regina Henschel, tdf#115813, tdf#125126, tdf#125181, tdf#125445)
  • Различные улучшения при импорте SmartArt из файлов PPTX Блог 1 Блог 2 Блог 3 Блог 4 (Miklos Vajna, Collabora)
Примеры SmartArt

Base

Помощник по миграции на Firebird, ранее доступный только в экспериментальном режиме, теперь предлагает пользователям мигрировать с их файлов Base HSQLDB по умолчанию.

Включая 13 исправленных проблем:

  • 5 для поддержки Firebird SDBC
  • 2 для поддержки MySQL/MariaDB
  • 1 для поддержки формата файлов dBase
  • 2 общих UI улучшения

Диаграммы

  • Реализована возможность отключить подпись легенды для серий (Markus Mohrhard) tdf#51671
  • Добавлена возможность выбора цветовой палитры в настройках цвета диаграммы (Jim Raykowski) tdf#105225

Math

  • Для альтернативного представления векторов реализован атрибут символа harpoon/wideharpoon, который комбинирует имя переменной с символом "гарпун" (U+20D1) также, как атрибут vect/widevec. tdf#120047 (Takeshi Abe).

BASIC

Ядро / Общие

  • Модуль сканирования LibreOffice TWAIN для Windows был переписан, как отдельный 32-битный исполняемый файл (twain32shim.exe). Это позволит и 32 и 64-битным версиям LibreOffice использовать 32-битный Windows TWAIN компонент. И, наконец, LibreOffice x64 для Windows может использовать сканирование. (tdf#114635 - Mike Kaganski, Collabora).
  • Количество сохранённых поисковых запросов в диалоге Найти и заменить может быть настроено через экспертные настройки в диалоге Сервис ▸ Параметры ▸ LibreOffice ▸ Расширенные возможности, параметр org::openoffice::Office::Common::Misc::FindReplaceRememberedSearches tdf#122322 (Heiko Tietze)
  • Новая команда .uno:InsertNarrowNobreakSpace, связанная с сочетанием клавиш ⇧ Shift+Alt+Space, вставляет узкий неразрывный пробел (U+202F) tdf#121596 (Heiko Tietze)
  • Now, like other controls for example the tree control, it is be possible to create and change properties of UNO grid control and UNO Hyperlink control within the Dialog-Editor tdf#53524,i#119731 (Shubham Goyal - Samuel Mehrbrodt, CIB).
  • Новый диалог Совет дня, который показывает полезную информацию один раз в день при первом запуске tdf#124238 (Heiko Tietze)
Tip of the Day
  • Информационная панель Что нового, указывающая на эти примечания к выпуску при первом запуске новой версии LibreOffice tdf#69042 (Heiko Tietze)
  • Выделение предложения (тройной щелчок) теперь доступен для привязки сочетаний клавиш в диалоге Настройка (по умолчанию сочетание не назначено) tdf#124552 (Heiko Tietze)
  • Если не модифицированный шаблон документа открывается в существующем окне, он больше не будет перезаписываться новым документом. Вместо этого новый документ откроется в новом окне. tdf#83722 (Katarina Behrens, CIB)

Новый функционал: Redaction

Теперь возможно редактировать ваши документы в LibreOffice для удаления/скрытия деликатной информации. статья в блоге (Muhammet Kara, Collabora)

Redaction tool in LibreOffice

Что?

Редактирование в смысле очистки - это зачернение или удаление текста в документе или результат таких усилий. Оно предназначено для обеспечения возможности избирательного раскрытия информации в документе, сохраняя при этом другие части документа в секрете. Как правило, результатом является документ, который подходит для публикации или распространения другим лицам, помимо предполагаемой аудитории исходного документа. Например, когда документ вызывается в суд в судебном деле, информация, не относящаяся конкретно к данному делу, часто редактируется. Redaction in Wikipedia

Хотя для этой цели на рынке существуют некоторые проприетарные программные приложения, они имеют свои собственные ограничения, такие как отсутствие поддержки форматов документов ODF. Благодаря отличной поддержке LibreOffice различных форматов файлов и нашей недавней работе по внедрению этой новой функции, теперь можно редактировать большинство ваших документов, не выходя из вашего любимого офисного пакета.

Как?

  • Откройте ваш документ в LibreOffice
  • Выберите пункт меню Сервис ▸ Redact и подождите, пока документ будет готовится для редактирования (конвертируется во внутренний мета-формат и передается в Draw)
  • Выполните редактирование, используя инструменты Прямоугольное редактирование или Свободное редактирование на панели инструментов Redaction
  • Сохраняйте и делитесь копиями документа для редактирования с коллегами в изменяемом (odg) или в PDF формате по вашему выбору
  • Когда вы будете готовы завершить редактирование, выберите нужный вариант из выпадающего списка Redacted Export на панели инструментов Redaction.

Некоторые примечания:

  • В результате вы получите немного пикселизированный отредактированный документ в формате PDF. В нем нельзя будет выделить текст и отредактированный (закрашенный) контент не будет виден
  • Во время редактирования фигуры, которыми вы скрываете контент будут прозрачными и серыми, так что пользователь может видеть, что он скрывает
Панель инструментов Redaction
  • На панели инструментов Redaction сейчас есть 4 инструмента (слева направо): Прямоугольное редактирование, Свободное редактирование, Экспорт отредактированного, Прямой экспорт в PDF
  • Инструмент Rectangle Redaction позволяет пользователю отмечать содержимое для редактирования, рисуя прозрачные прямоугольники, закрывающие содержимое.
  • Инструмент Freeform Redaction позволяет пользователю пометить содержимое для редактирования путем рисования линий / многоугольников произвольной формы, охватывающих содержимое.
  • Выпадающий список Redacted Export имеет два инструмента: Redacted Export (Black) и Redacted Export (White). При выборе они завершат работу над документом (преобразовав прозрачные серые формы редактирования в непрозрачные черные или белые формы) и экспортируют их в пиксельный PDF-файл. Вариант White может быть предпочтительным для экономии тонера во время печати.
  • Значок Прямой экспорт в PDF позволит пользователю экспортировать документ в обычный документ PDF.

Справка LibreOffice

  • Добавлены новые страницы Справки по программированию макросов на Python (Alain Romedenne, Olivier Hallot)
  • Добавлены страницы справки по недокументированным объектам и функциям BASIC (Alain Romedenne, Olivier Hallot)
  • Фрагменты кода BASIC и Python теперь лучше выглядят на страницах Справки (Olivier Hallot)

Bascode rendering.png

  • Фрагменты кода BASIC и Python теперь могут быть скопированы в буфер обмена по щелчку мышью для дальнейшего использования tdf#122548 (Olivier Hallot)
  • Extension of the XML dictionary (DTD) для упрощения разметки для страниц Справки (Olivier Hallot)
  • Создан онлайн редактор Справки (Olivier Hallot, Mike Saunders)
  • Произведен рефакторинг значков Math в формат SVG (Mark Robbinson, Olivier Hallot)
  • Произведен рефакторинг имён файлов Справки для Draw (Ilmari Lauhakangas, Olivier Hallot)
  • Чистка кода и исправление опечаток (Sophia Schröder, Andrea Gelmini)
  • Задокументированы функции Calc CONCAT, TEXTJOIN, IFS, SWITCH (Olivier Hallot, Wilfried Donkers)
  • Функции Calc теперь содержат номер выпуска LibreOffice, в котором их реализовали (Olivier Hallot, Mike Kaganski)

Фильтры

Улучшения в фильтре экспорта EMF+

  • добавлено поддержка правильного вращения для Эллипса, Арки и Пирога tdf#122498 (Bartosz Kosiorek)
  • добавлена поддержка для вращения и сдвига изображения tdf#122557 (Bartosz Kosiorek)
  • добавлена поддержка прозрачности для нарисованных линий tdf#122559 (Bartosz Kosiorek)
  • правильная толщина линии tdf#122646 (Bartosz Kosiorek)
  • добавлена поддержка прозрачности для линейных градиентов tdf#124424 (Bartosz Kosiorek)

Улучшения в фильтре экспорта PDF

  • Добавлена поддержка экспорта в формат PDF/A-2, с соответствующим улучшением интерфейса для возможности выбрать PDF/A-1 или PDF/A-2 tdf#62728 (Thorsten Behrens, CIB)
  • Исправлены ошибки проверки валидации PDF для PDF/A tdf#113448 (Thorsten Behrens, CIB)

Улучшения фильтров OOXML

  • Добавлена поддержка экспорта шаблона электронной таблицы в формат .xltx tdf#99438 (Vasily Melenchuk, CIB)
  • Добавлена поддержка экспорта шаблона текстового документа в формат .dotx commit (Vasily Melenchuk, CIB)
  • Улучшена поддержка сводных таблиц MS Excel tdf#123939, tdf#124651, tdf#113908, tdf#124736, tdf#124772, tdf#124810, tdf#124881, tdf#124883, (Mike Kaganski, Collabora)
  • Теперь при экспорте в PPTX объекты SmartArts сохраняются для сохранения возможности их редактирования в PowerPoint commit (Grzegorz Araminowicz, Collabora)

Улучшения экспорта Tagged PDF

Several enhancements were made to Tagged PDF export in order to improve accessibility of produced documents and PDF standard compliance, in particular:

  • better tagging of bullets and numbered lists
  • export of image title and description (alt text)
  • images on slide/page background are now exported as artifacts, thus not announced by screenreader

This work has been sponsored by Blackboard Ally (Armin Le Grand, Katarina Behrens, CIB)

Интерфейс пользователя

Ленточный интерфейс

  • Новый вариант Вкладки компактные доступен в Writer, Calc, Impress и Draw. Попробуйте его, выбрав в меню Вид ▸ Интерфейс пользователя. (Andreas Kainz)
Новый вариант Вкладки компактные
  • Новый вариант Контекстная однострочная готов для использования в Writer и Draw. Попробуйте его, выбрав в меню Вид ▸ Интерфейс пользователя. (Andreas Kainz)
New Contextual Single UI for Writer and Draw.

Общие улучшения

Классические панели инструментов

  • Панель инструментов More controls была удалена и все инструменты с этой панели были перемещены на панель Элементы управления. Это было сделано для всех модулей LibreOffice. tdf#112411 (Roman Kuznetsov)

Темы значков

  • Тема значков Sifr получила огромное обновление (Andreas Kainz)
Сравнение значков темы Sifr между LibreOffice 6.2 (Вверху) и LibreOffice 6.3 (Внизу).
  • Тема значков Karasa Jaga была переработана с размера 22px на размер 24px. tdf#124808 (Rizal Muttaqin)
Вверху значки Karasa Jaga в версии 6.2, внизу - в версии 6.3

Диалоги

  • Изменены шрифты в диалоге установщика LibreOffice в Windows с Tahoma 8px на Segoe UI 9px, также изменена ширина диалога. tdf#99891 (Roman Kuznetsov)
Вверху - старый диалог, внизу - новый

Боковая панель

  • Ширина Боковой панели теперь настраивается через экспертную опцию Office/UI/Sidebar/General/MaximumWidth config option. tdf#124255 (Samuel Mehrbrodt, CIB)
  • Некоторые улучшения по управлению различной шириной для секций Боковой панели коммит 1 d0c73ce13c02c37fcc094ac6612d6a8eee2a4026 коммит 2 a58391b1f61db702a5246c5a33717cbba68c5252 (Samuel Mehrbrodt, CIB)
  • Изменены имена для стилей списка типа Маркированный список в Боковой панели Writer. tdf#124471 (Roman Kuznetsov)
Изменённые имена стилей в Боковой панели. До изменения - слева, после - справа

Вкладки Calc/Draw

  • Вкладки в Calc и в Draw были изменены для большего удобства работы tdf#124572 (Tomaž Vajngerl, Collabora)
Слева вкладки Calc в версии 6.2, справа - в версии 6.3
Слева вкладки Draw в версии 6.2, справа - в версии 6.3

Панель для ввода формул Calc

  • Выпадающий элемент управления в панели для ввода формул Calc был изменён для решения некоторых проблем отображения. tdf#101443 (Thorsten Wagner)
Вверху - до изменения, внизу - после

Онлайн

Администрирование

  • Улучшена обработка информации об ошибках загрузки хранилища для хостинга / разработки (Szymon Kłos, Collabora)
  • Улучшено ведение логов (Tor Lillqvist, Michael Meeks, Collabora)

Интеграция

  • Местоположение онлайн Справки теперь настривается (Andras Timar, Ashod Nakashian , Collabora)
  • Теперь можно настроить, что печать недоступна для пользователя (Ashod Nakashian, Collabora)
  • Разрешить скрытие списка пользователей (Szymon Kłos, Collabora)

Настройка

Следующие методы PostMessage были добавлены, чтобы позволить настройку интерфейса пользователя: (Samuel Mehrbodt, CIB)

  • Hide_Menubar/Show_Menubar - чтобы скрывать/показывать строку меню
  • Remove_Button - чтобы удалять кнопку из панели инструментов
  • Insert_Button - теперь имеет параметр для указания позиции вставки, а также команду UNO, которая будет выполняться при щелчке

Производительность

  • Улучшена скорость обработки онлайн-документов (Michael Meeks, Ashod Nakashian, Collabora)
  • Более быстрая загрузка страниц (Henry Castro, Collabora)

HiDPI

  • Правильное отображение элементов управления уровня группы на дисплеях высокого разрешения (Marco Cecchetti, Collabora)

Подписывание документов

  • Подписывание, экспорт и загрузка PDF, ODT и DOCX теперь может быть сделана в одно комбинированное действие (Tomaž Vajngerl, Collabora)
  • Улучшения в отображении личности текущего пользователя на панели инструментов Подпись (Tomaž Vajngerl, Collabora)
  • Улучшен диалог Vereign Sign, а также панель инструментов (Tomaž Vajngerl, Jan Holesovsky, Miklos Vajna, Collabora)
  • Добавлены элементы конфигурации для панели инструментов Vereign (Andras Timar, Collabora)

Диаграммы

  • Улучшено перетаскивание сегментов диаграммы типа круговая (Marco Cecchetti, Collabora)
  • Улучшено выделение элементов диаграммы (Marco Cecchetti, Collabora)
More Chart features available

Взаимодействие с пользователем

  • Improvements in handling online user dialogs (Szymon Kłos, Collabora)
  • Easier pasting experience for the user (Jan Holesovsky, Collabora)
  • If the user clicks a link, tell which site they are about to visit and ask if that is OK (Jan Holesovsky, Szymon Kłos, Collabora)
Ask user before opening a Hyperlink
  • Improved keyboard handling for Delete and Insert key (Iván Sánchez Ortega, Collabora)
  • Improved context menu’s on iOS Safari (Henry Castro, Collabora)
  • The user can now paste text into fields in dialogs (Henry Castro, Collabora)
  • Many improvements and additions to the menu (Ashod Nakashian, Collabora)
  • Improved selection and input in text boxes (Henry Castro, Collabora)
  • The status bar now indicates when a document is modified (Henry Castro, Collabora)
  • Extra toolbar command names are available (Jan Holesovsky, Collabora)
  • The zooming of the Insert Hyperlink dialog is fixed (Szymon Kłos, Collabora)
  • Better width of About and Help popup windows on narrow and wide screens (Andras Timar, Collabora)

Misc

  • Improved selection and rotating of images in Writer (Marco Cecchetti, Collabora)
Rotating of Images now easier
  • Show user colors when no avatar is available (Szymon Kłos, Collabora)
  • Make avatar unified and colored (Szymon Kłos, Collabora)
  • Microsoft Visio files are now opened (read-only) in the application (Tor Lillqvist, Collabora)
Microsoft Visio files now opened
  • Share and Print buttons should be enabled also in read only mode (Jan Holesovsky, Collabora)
  • Language support: more possibilities for handling languages/locales added (Henry Castro, Ashod Nakashian, Collabora)
  • When creating a new document online, the user now can chose from (the installed) templates (merttumer, Collabora)
Custom Templates now supported
  • The user now has paste options in the context menu (Henry Castro, Collabora)
  • Updated Slovenian translation (Andras Timar, Collabora)

Calc

  • The user now has the full power of the conditional formatting dialogs in Calc (Henry Castro, Jan Holesovsky, Collabora)
Conditional formatting in Calc
  • Improved inserting rows with the context menu (Marco Cecchetti, Collabora)
  • In Calc, users now have the following menus available (Mert Tumer, Collabora):
    • Insert ▸ Edit Header and Footer,
    • Tools ▸ Goal Seek,
    • Format ▸ Format Page,
    • Format ▸ Conditional Formatting ▸ Manage
  • Reduce read only toolbar height in Calc (Szymon Kłos, Collabora)

Impress

  • In Impress, users now can use Insert ▸ Header and Footer (Miklos Vajna, Collabora)
  • Impress toolbar now has the button Insert Text Box, which directly inserts at the cursor position (Jan Holesovsky, Collabora)
  • Much improved update of preview in Impress online while there is a change in selection or editing (Ashod Nakashian, Collabora)
  • In Impress, users now have dialogs for formatting characters, paragraphs and the page (Jan Holesovsky, Collabora)
Insert > Chart available in Writer
  • The Insert Chart... toolbar button now also is available in Impress (Jan Holesovsky, Collabora)

Writer

  • Improved displaying of comments, so that those from various places do not overlap (Marco Cecchetti, Collabora)
  • In Writer, users can now add and change watermarks via the dialog (Mert Tümer, Collabora)
Add and edit Watermark in Writer Online
  • In Writer, users can now use the menu (Miklos Vajna, Collabora):
    • Insert ▸ Section
    • Format ▸ Section, and
    • Insert ▸ Table of Contents and Index ▸ Index Entry or .... ▸ Bibliography Entry
  • The Insert Chart… toolbar button now also is available in Writer (Jan Holesovsky, Collabora)
Insert Charts in Writer

Localization

Incorporation of other languages

Improvements to proofing tools and language support

see details on the changes: [1]

  • Afrikaans. The spelling dictionary was updated.
  • Breton. The spelling dictionary was updated.
  • Danish. The spelling dictionary was updated.
  • English (GB). The spelling dictionary was updated.
  • Galician. The spelling dictionary was updated.
  • Serbian. The spelling dictionary was updated.
  • Slovenian. The thesaurus was updated.
  • Spanish. The spelling dictionary was updated.
  • Thai. The spelling dictionary was updated.

Feature removal / deprecation

Java

Support for Java 5 has been removed. Java 6 is now the oldest supported version. (Samuel Mehrbrodt, CIB)

General

GStreamer 0.10 deprecation

Support for GStreamer 0.10 is deprecated and will no longer be present in the subsequent LibreOffice version 6.4 (commit 6b911ae9eb9484bebbdc1323210020486f5ef33f). GStreamer 1.0 continues to be supported.

GUI

KDE4 VCL plugin

KDE4 is out of maintenance upstream since November 2014. LibreOffice’s KDE4 VCL plugin has been removed and binaries provided by TDF have switched to KDE5 as the official backend. commit 410bf59de02192c2daf1158b9de76ec0ebab4c56

GTK+2 VCL plugin

The GTK+2 VCL backend is deprecated and will be removed in the next version.

Personalization

Firefox Personas search & apply functionality has been removed from the personalization dialog (Tools ▸ Options ▸ LibreOffice ▸ Personalization) as per the ESC & Design Team decisions, after major changes on the Mozilla side, which made it impossible to use their API and the themes data for us. The default personas are unaffected, and still functional. Future improvements and more features are planned by the Design Team, thanks to now having a clean slate, without the burden of chasing an external API. Firefox Themes are dead; long live the LibreOffice Themes! :) tdf#123831 (Muhammet Kara, Collabora)

Please beware that although users may continue using their already installed personas as long as they don’t switch to a default persona; once a default persona is applied, there is no way to go back to the custom theme via normal means.

Platform Compatibility

Mac

  • Statusbar shows Insert in normal mode on macOS (additional to Overwrite) to draw attention to the context menu tdf#107918 (Heiko Tietze)

Windows

Linux

KDE 5 + Qt5

KDE5/Qt5 VCL plugin received substantial improvement since its first release in LibreOffice 6.2, including but not limited to:

(Jan-Marek Glogowski, Katarina Behrens (CIB), Michael Weghorn (LHM), Aleksei Nikiforov (BaseAlt), Michael Stahl (CIB))

The full list of KDE5 bugs fixed in 6.3 can be found here. Further bugs and missing features are tracked via the KDE meta bug tdf#102495.

32-bit builds removals

Binary Linux x86 (32-bit) releases will be demoted. There will be no Linux x86 builds produced by TDF after 6.2. This does not mean that Linux x86 compatibility will be removed. If you need a 32 bit build, please have a look at your distribution.

API changes

UNO API changes

  • Registering a XMouseListener/XKeyListener to a XWindow will now submit mouse/key events even if technically the events happened in a widget inside that window. (Samuel Mehrbrodt, CIB) tdf#122920

Configuration changes

SDK changes

Android Viewer

New Features