发行说明/6.3

From The Document Foundation Wiki
Jump to: navigation, search
This page is a translated version of the page ReleaseNotes/6.3 and the translation is 5% complete.

Outdated translations are marked like this.
Other languages:
dansk • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎日本語 • ‎português do Brasil • ‎русский • ‎slovenščina • ‎Tiếng Việt • ‎中文(中国大陆)‎


Contents

关于本页

Writer 文本文档

  • 自动更正选项“更正词首的两个大写字母” 的例外列表功能已被扩展。扩展之后,当触发“每个句子以大写字母开头”或“纠正 cCAPS lOCK 键的意外使用”选项而对单词进行大小写更正时,会同时考虑该例外列表。这样就能避免对类似 mRNA, iPhone, fMRI 等合法单词的自动更正。该选项已被重命名为“前两个字母为大写或首字母为小写的新词”。tdf#121779 (Mike Kaganski - Collabora).
  • 新增 UNO 命令 .uno:TableCellBackgroundColor,以允许设置单个或多重选定的表格单元格的背景颜色 tdf#82504 (Jim Raykowski)
  • 在导航窗口的右键菜单中新增“将大纲发送到剪贴板”选项(在“标题”中右键单击)tdf#123395 (Wenzhe Pei).
  • 变量输入字段 插入 ▸ 字段 ▸ 更多字段... ▸ 变量 ▸ 输入字段 现在可以在行中编辑,这与已经可以行中编辑的函数输入字段相同 插入 ▸ 字段 ▸ 更多字段... ▸ 函数 ▸ 输入字段 tdf#123968 (Michael Stahl, CIB)
  • 更新索引/目录操作现在可以撤销和恢复,并且不会清楚撤销堆栈。tdf#38703 (Michael Stahl, CIB)
  • 从Calc电子表格向Writer文本文档复制粘贴功能的改进:仅粘贴经过筛选的可见单元格 tdf#124646 (László Németh, NISZ)
  • 页面背景现在会覆盖整个页面,而不是仅覆盖页边距以内的区域 tdf#33041 (László Németh, NISZ)
  • 表格单元格及文本框新增“从下到上,从左到右”文字方向,更好地与Word兼容。博文1 博文2 (Miklos Vajna, Collabora)
  • 可以从 DOCX drawingML 组合形状中导入图表博文 (Miklos Vajna, Collabora)

可互操作的基于文本的表单控件

  • 可选的“表单”菜单布局,与微软Office类似。 (Tamás Zolnai, Collabora)
  • 实现了针对老旧表单控件的GUI (Tamás Zolnai, Collabora)

参见:Form controls in LibreOffice

打开和保存功能的性能提升

  • 书签性能的改进。导出速度提升了1.5倍。tdf#117066 (Noel Grandin, Collabora)
  • 大表格性能的改进。tdf#84635 (Noel Grandin, Collabora)
  • 内嵌字体性能的改进 tdf#69060 (Mike Kaganski, Collabora)
  • 对某些ODT文件性能的改进 tdf#63640 (Noel Grandin, Collabora)

Calc 电子表格

  • Added UNO API to let cell anchored graphics resize with the cell (Samuel Mehrbrodt, CIB) tdf#124329
  • Added new Russian ruble currency symbol to currency formats. It will display the character (U+20BD) instead of руб. or other localized variants (Eike Rathke, Red Hat) tdf#96711
  • Added new drop-down widget into formula bar instead old tool Sum (Gagandeep Singh) tdf#120697
New drop-down widget in formula bar
  • User can disable the extra dialog for search results. For activate of this dialog use option Show summary of replaced cells in dialog Tools ▸ Options ▸ Calc ▸ View ▸ Window tdf#87965 (Heiko Tietze)
Search results
  • Added a new checkbox in Data ▸ Statistics ▸ Moving Average dialog that allows trimming of the input range to the actual data content before computing moving-average. This checkbox is enabled by default. Also fixed the underlying performance problem even for the case when this checkbox is disabled (Dennis Francis, Collabora) tdf#99938.
Moving Average dialog with the new “trim input range” checkbox.
  • The auto-filter popup no longer flickers on Windows without OpenGL tdf#101086 (Miklos Vajna, Collabora)
  • It's now possible to sort range containing a protected labels row tdf#119804 (Martin van Zijl)

Rework Data ▸ Statistics ▸ Sampling dialog

All work was made by Eike Rathke commit

  • Add “With replacement” checkbutton
    • checked: WR (with replacement, put back after draw), larger sample size than population size possible
      • mutually exclusive with “Keep order”
    • unchecked: WOR (without replacement, do not put back after draw), sample size limited to population size
      • automatically unchecked for “Periodic” samples
  • Add “Keep order” checkbutton
    • checked: samples are drawn in order of population data
      • WOR method mutually exclusive with “With replacement”
      • automatically checked for “Periodic” samples
    • unchecked: samples are drawn in random order
Sampling dialog with the new options, “With replacement” and “Keep order”
  • Limit “Sample size” and “Period” input fields to size of population for all WOR methods
    • when limiting, increment “Sample size” and “Period” up to their last known value when enlarging the population size

Previously, for “Periodic” samples the “Period” field was never limited, which for populations of smaller size makes no sense.

The new recent implementation for “Random” without “Keep order” and without “With replacement” set (WOR) strictly needs “Sample size” limited to population size.

New spreadsheet functions

FOURIER() 函数

FOURIER(Array, GroupedByColumns, Inverse, Polar, MinimumMagnitude) is a matrix formula that computes discrete Fourier transform [DFT] of an input array (first argument) using a couple of Fast Fourier Transform algorithms. All features of this formula will also be available graphically via the dialog Data ▸ Statistics ▸ Fourier analysis tdf#74664 blog (Dennis Francis, Collabora)

The data in input array(first argument) can be:

  • grouped by columns (needs to be indicated by flag GroupedByColumns = TRUE). In this case the array can contain 1 or 2 columns, where the first column contains the real part of input sequence and second column if present contains the imaginary part of the input sequence. If there is only 1 column, the input sequence is treated as purely real.
  • grouped by rows (needs to be indicated by flag GroupedByColumns = FALSE). In this case the array can contain 1 or 2 rows, where the first row contains the real part of input sequence and second row if present contains the imaginary part of the input sequence. If there is only 1 row, the input sequence is treated as purely real.

The third argument “Inverse” is a boolean flag to indicate whether an inverse DFT needs to be computed. This argument is optional and the default value is FALSE.

The fourth argument Polar is a boolean flag to indicate whether the final output needs to be in polar coordinates. This argument is optional and the default value is FALSE.

The result of DFT consists of two columns - first column contains the real parts (or the magnitudes if Polar=TRUE) and second column contains the imaginary parts (or the phases if Polar=TRUE).

There is a 5th optional parameter, MinimumMagnitude. This parameter is used only if Polar=TRUE. All frequency components with magnitude less than MinimumMagnitude will be suppressed with a zero magnitude-phase entry. This is very useful when looking at the magnitude-phase spectrum of a signal because there is always some very tiny amount of rounding error when doing FFT algorithms and results in incorrect non-zero phase for non-existent frequencies. By providing a suitable value to this parameter, these non-existent frequency components can be suppressed. By default the value of this 5th parameter is 0.0, so *no* suppression is done by default.

Fourier Analysis Tool in action

Performance

  • Speed-up loading of XLSX files. tdf#67629 tdf#89522 tdf#121094 (Noel Grandin, Collabora)
  • Speed-up loading of ODS files. tdf#120445 tdf#85482 (Noel Grandin, Collabora)
  • Speed-up loading and rendering of Calc files with VLOOKUP (Serge Krot, CIB / Eike Rathke, Red Hat) tdf#121052
  • Speed-up saving files to XLS format. tdf#85470 (Noel Grandin, Collabora)
  • Cache MDDS positions to improve performance while working with large datasets tdf#112383 (Luboš Luňák, Collabora)
Improved performance in Calc
  • See the full list of perf Calc bugs fixed in this version here

Changed spreadsheet functions

Impress & Draw

  • Users may now drag’n’drop multiple Impress animations to reorder them. (Brian Fraser) commit
  • Introduce an expert option ‘WriteLayerStateAsConfigItem’ with default value ‘true’. If you set it to ‘false’, the visible/printable/locked state of layers are only written ODF conform to part styles.xml, otherwise to settings.xml in addition. You might need the option ‘false’ to avoid inconsistency in case you manipulate layers via macro. (Regina Henschel) commit
  • OOXML preset shapes as used by PowerPoint or SoftMaker had some glitches in handle-movement, when you tried to alter the shapes in LibreOffice. The shape outline moved in opposite direction of the handle movement, or the handle jumped to a new location, when you touched it, or the handle was not movable at all. That is fixed for most shapes now. (Regina Henschel, tdf#115813, tdf#125126, tdf#125181, tdf#125445)
  • Various improvements to the import of SmartArt from PPTX files Blog post 1 Blog post 2 blog post 3 blog post 4 (Miklos Vajna, Collabora)
Microsoft compatible forms menu in Writer

Base

Firebird Migration Assistant, previously available only in experimental mode, will prompt users to migrate their Base HSQLdb embedded files by default.

Includes 13 resolved issues, including:

  • 5 for Firebird sdbc support
  • 2 for MySQL/Mariadb support
  • 1 dBase file format support
  • 2 general UI enhancement

Chart

  • Implement feature to disable legend entry for series (Markus Mohrhard) tdf#51671
  • Add palette selection to options charts default colors (Jim Raykowski) tdf#105225

Math

  • Introduce attributes harpoon and wideharpoon for an alternative representation of vectors, which combines a variable name with the harpoon symbol (U+20D1 ⃑ ) as like attributes vec and widevec tdf#120047 (Takeshi Abe).

BASIC

Core / General

  • LibreOffice TWAIN module on Windows was reimplemented as a separate 32-bit shim executable (twain32shim.exe). This allows both 32-bit and 64-bit LibreOffice to use 32-bit TWAIN Windows component. Now finally LibreOffice x64 for Windows is able to use scanner (tdf#114635 - Mike Kaganski, Collabora).
  • The number of saved searches in the Find & Replace dialog can be adjusted per expert configuration Tools ▸ Options ▸ LibreOffice ▸ Advanced org::openoffice::Office::Common::Misc::FindReplaceRememberedSearches tdf#122322 (Heiko Tietze)
  • New command .uno:InsertNarrowNobreakSpace introduced bound to ⇧ Shift+Alt+Space that inserts a non-breakable narrow space (U+202F) tdf#121596 (Heiko Tietze)
  • Added ability to create and change properties of UNO grid control and UNO Hyperlink control within the Dialog-Editor tdf#53524,i#119731 (Shubham Goyal - Samuel Mehrbrodt, CIB).
  • Tip-Of-The-Day dialog shows useful information once per day on startup tdf#124238 (Heiko Tietze)
Tip of the Day
  • What's-New infobar pointing to the release notes when a new version is started for the first time tdf#69042 (Heiko Tietze)
What’s New infobar
  • Sentence selection (triple click) is available for keyboard customization now (no default shortcut assigned) tdf#124552 (Heiko Tietze)
  • If an unmodified template document is opened in an existing window, it will no longer be overwritten by a new document. Instead, a new document will open in a new window tdf#83722 (Katarina Behrens, CIB)
  • The Apple Advanced Typography (AAT) layout is now supported on all platforms. commit (Khaled Hosny)
  • Ability to read and optionally generate MSO lockfiles was added. Now LibreOffice can report who of MS Office users has locked a document by reading the lock files generated by MS Office; and when "Create MSO lock file" is checked at Tools ▸ Options ▸ Load/Save ▸ Microsoft Office, LibreOffice would generate such files in addition to own lock files, to allow MS Office users to know who has locked documents, too. tdf#34171, commit (Mike Kaganski, Collabora / Tamás Zolnai, Collabora)

New Feature: Redaction

Now it is possible to redact your documents with LibreOffice to remove/hide sensitive information. blog post (Muhammet Kara, Collabora)

Redaction tool in LibreOffice

What?

Redaction in its sanitization sense is the blacking out or deletion of text in a document, or the result of such an effort. It is intended to allow the selective disclosure of information in a document while keeping other parts of the document secret. Typically the result is a document that is suitable for publication or for dissemination to others than the intended audience of the original document. For example, when a document is subpoenaed in a court case, information not specifically relevant to the case at hand is often redacted. Redaction in Wikipedia

Although there are some proprietary software applications in the market for this purpose, they have their own limitations like lack of support for open/libre document formats. Thanks to LibreOffice's great support for various file formats, and our recent work on implementing this new feature on top of it, it is now possible to redact most of your documents without leaving the comfort of your favourite office suite.

How?

  • Open your document in LibreOffice
  • Click (Tools ▸ Redact) from the main menu, and wait for your document to be prepared for redaction (converted to an internal meta-format, and transferred to Draw)
  • Do the redaction by using the “Rectangle Redaction,” and the “Freeform Redaction” tools on the “Redaction Toolbar”
  • Save & share the in-redaction copies of the document with peers either in the modifiable (odg) or the verbatim (pdf) format at your option
  • Once you are ready to finalize the redaction, click the desired option on the “Redacted Export” tool on the Redaction toolbar

Some Notes:

  • As a result, you will have a pixellized version of the redacted document in PDF. There will be no selectable text in it, and the redacted content will be non-existent.
  • During redaction, the redaction shapes will be transparent and in grey so that the user can see what they are redacting.
The Redaction Toolbar
  • There are currently 4 tools on the Redaction toolbar (from left to right): Rectangle Redaction, Freeform Redaction, Redacted Export, Direct Export to PDF
  • The Rectangle Redaction tool allows the user to mark the content for redaction by drawing transparent rectangles covering the content
  • The Freeform Redaction tool allows the user to mark the content for redaction by drawing freeform lines/polygons covering the content
  • The “Redacted Export” button box has two options: “Redacted Export (Black)” and “Redacted Export (White).” When clicked, it will finalize your document (by converting the transparent grey redaction shapes to opaque black or white shapes), and export as a pixellized PDF file. The “White” option might be preferred to save toner while printing.
  • The Direct Export to PDF button allows the user to take an in-redaction copy of the document in PDF to share as a verbatim copy for review

LibreOffice Help

  • Help pages on Python Macro programming (Alain Romedenne, Olivier Hallot)
  • More pages on undocumented BASIC objects and functions (Alain Romedenne, Olivier Hallot)
  • Python and BASIC code fragments better rendered in Help pages (Olivier Hallot)

Bascode rendering.png

  • Python and Basic code fragments can now be copied to clipboard on a mouse click for later use - tdf#122548 (Olivier Hallot)
  • Extension of the XML dictionary (DTD) to simplify markup for Help pages (Olivier Hallot)
  • The Online Help Editor (Olivier Hallot, Mike Saunders)
  • Refactoring of Math icons to SVG (Mark Robbinson, Olivier Hallot)
  • Refactoring of Help file names for Draw (Ilmari Lauhakangas, Olivier Hallot)
  • Code cleanups and typo fixing (Sophia Schröder, Andrea Gelmini)
  • Calc functions CONCAT, TEXTJOIN, IFS, SWITCH documented (Olivier Hallot, Wilfried Donkers)
  • Calc functions now indicates the LibreOffice release of their implementation (Olivier Hallot, Mike Kaganski)

Filters

Improvements of the EMF+ export filter

  • add proper rotation support for Ellipse, Arc and Pie tdf#122498 (Bartosz Kosiorek)
  • add support for image rotation and shearing tdf#122557 (Bartosz Kosiorek)
  • add transparency support for drawing lines tdf#122559 (Bartosz Kosiorek)
  • correct line weight tdf#122646 (Bartosz Kosiorek)
  • add transparency support for linear gradients tdf#124424 (Bartosz Kosiorek)

Improvements of the PDF export filter

  • added support for PDF/A-2 export, switched UI to be able to use either PDF/A-1 or PDF/A-2 tdf#62728 (Thorsten Behrens, CIB)
  • fixed a number of veraPDF-reported PDF validation issues for PDF/A tdf#113448 (Thorsten Behrens, CIB)

Improvements of OOXML filters

  • Added support for export to spreadsheet template file .xltx tdf#99438 (Vasily Melenchuk, CIB)
  • Added support for export to text document template file .dotx commit (Vasily Melenchuk, CIB)
  • Improve XLSX Pivot table interoperability tdf#123939, tdf#124651, tdf#113908, tdf#124736, tdf#124772, tdf#124810, tdf#124881, tdf#124883, (Mike Kaganski, Collabora)
  • Preserve SmartArts when exporting PPTX files to allow editing in PowerPoint commit (Grzegorz Araminowicz, Collabora)
  • Correctly import Text Camera Rotation with Powerpoint PPTX import tdf#126060 (Gülşah Köse, Collabora)

Improvements of Tagged PDF export

Several enhancements were made to Tagged PDF export in order to improve accessibility of produced documents and PDF standard compliance, in particular:

  • better tagging of bullets and numbered lists
  • export of image title and description (alt text)
  • images on slide/page background are now exported as artifacts, thus not announced by screenreader

This work has been sponsored by Blackboard Ally (Armin Le Grand, Katarina Behrens, CIB)

GUI

Notebookbar

  • The new Tabbed Compact UI is ready for release! Writer, Calc, Impress and Draw have complete Tabbed Compact UI versions. Try it out by selecting it in (View ▸ User Interface). (Andreas Kainz)
The new Tabbed Compact UI.
  • The new Contextual Single UI is ready for release in Writer and Draw! Try it out by selecting it in (View ▸ User Interface). (Andreas Kainz)
New Contextual Single UI for Writer and Draw.

General Improvements

Classic Toolbars

  • Toolbar More controls was deleted and all tools from this toolbar were moved to toolbar Form Controls. It was made for all modules of LibreOffice. tdf#112411 (Roman Kuznetsov)

Icon Theme

  • Sifr icon theme got a huge update (Andreas Kainz)
Comparison between Sifr icons in LibreOffice 6.2 (Top) with Sifr icons in LibreOffice 6.3 (Bottom).
  • Karasa Jaga icon theme reworked from 22px*22px size to 24px*24px one. tdf#124808 (Rizal Muttaqin)
To up Karasa Jaga large icons in version 6.2, to down - in version 6.3
  • Karasa Jaga icon theme got SVG (Scalable Vector Graphics) version. tdf#125368 (Rizal Muttaqin)

Dialogs

  • Changed fonts in LibreOffice’s installer dialog in Windows from Tahoma 8 to Segoe UI 9 and changed width of windows of dialog tdf#99891 (Roman Kuznetsov)
Above - old dialog, bottom - new

Sidebar

Changed Bullet style’s names in Style section of Sidebar. Before - to left, after - to right

Calc/Draw tabs

  • Calc and Draw tabs were changed for more visible and usability tdf#124572 (Tomaž Vajngerl, Collabora)
To left Calc tabs in version 6.2, to right - in version 6.3
To left Draw tabs in version 6.2, to right - in version 6.3

Calc Formula bar

  • Drop-down control in Calc Formula bar was reworked for solve some visual problems tdf#101443 (Thorsten Wagner)
On top - before, on bottom - after

Misc

Support for Amazon Corretto added.

Online

Admin

  • Improved handling of information about storage loading failures for hosting/development (Szymon Kłos, Collabora)
  • Improved logging (Tor Lillqvist, Michael Meeks, Collabora)

Integration

  • The location of the online Help is now configurable (Andras Timar, Ashod Nakashian, Collabora)
  • It can now be configured that printing is not available for the user (Ashod Nakashian, Collabora)
  • Inform people working on integrations if the Online they are using is supporting (new) features (Jan Holesovsky, Collabora)
  • Allow the hiding of the list of users (Szymon Kłos, Collabora)

Customization

The following PostMessage methods have been added to allow UI customization: (Samuel Mehrbodt, CIB)

  • Hide_Menubar/Show_Menubar - to hide/show the menu bar
  • Remove_Button to remove a button from the toolbar
  • Insert_Button now has a paramter to specify the insert position as well as the UNO command to be executed on click

Performance

  • Improved speed of handling online-documents (Michael Meeks, Ashod Nakashian, Collabora)
  • Faster loading of pages (Henry Castro, Collabora)

HiDPI

  • Correct display of group level controls on hidpi display (Marco Cecchetti, Collabora)

Document signing

  • Signing, export and upload of PDF, ODT and DOCX can now be done in one combined action (Tomaž Vajngerl, Collabora)
  • Improvements in showing identity of the currently logged in on the signing toolbar (Tomaž Vajngerl, Collabora)
  • The Vereign Sign dialog has been improved, as well as the toolbar (Tomaž Vajngerl, Jan Holesovsky, Miklos Vajna, Collabora)
  • Added config items for Vereign toolbar (Andras Timar, Collabora)

Charts

  • Improved dragging for pie segments of charts (Marco Cecchetti, Collabora)
  • Improving selecting of chart elements (Marco Cecchetti, Collabora)
More Chart features available

User interaction

  • Improvements in handling online user dialogs (Szymon Kłos, Collabora)
  • Easier pasting experience for the user (Jan Holesovsky, Collabora)
  • If the user clicks a link, tell which site they are about to visit and ask if that is OK (Jan Holesovsky, Szymon Kłos, Collabora)
Ask user before opening a Hyperlink
  • Improved keyboard handling for Delete and Insert key (Iván Sánchez Ortega, Collabora)
  • Improved context menu’s on iOS Safari (Henry Castro, Collabora)
  • The user can now paste text into fields in dialogs (Henry Castro, Collabora)
  • Many improvements and additions to the menu (Ashod Nakashian, Collabora)
  • Improved selection and input in text boxes (Henry Castro, Collabora)
  • The status bar now indicates when a document is modified (Henry Castro, Collabora)
  • Extra toolbar command names are available (Jan Holesovsky, Collabora)
  • The zooming of the Insert Hyperlink dialog is fixed (Szymon Kłos, Collabora)
  • Better width of About and Help popup windows on narrow and wide screens (Andras Timar, Collabora)

Misc

  • Improved selection and rotating of images in Writer (Marco Cecchetti, Collabora)
Rotating of Images now easier
  • Show user colors when no avatar is available (Szymon Kłos, Collabora)
  • Make avatar unified and colored (Szymon Kłos, Collabora)
  • Microsoft Visio files are now opened (read-only) in the application (Tor Lillqvist, Collabora)
Microsoft Visio files now opened
  • Share and Print buttons should be enabled also in read only mode (Jan Holesovsky, Collabora)
  • Language support: more possibilities for handling languages/locales added (Henry Castro, Ashod Nakashian, Collabora)
  • When creating a new document online, the user now can chose from (the installed) templates (merttumer, Collabora)
Custom Templates now supported
  • The user now has paste options in the context menu (Henry Castro, Collabora)
  • Updated Slovenian translation (Andras Timar, Collabora)

Calc

  • The user now has the full power of the conditional formatting dialogs in Calc (Henry Castro, Jan Holesovsky, Collabora)
Conditional formatting in Calc
  • Improved inserting rows with the context menu (Marco Cecchetti, Collabora)
  • In Calc, users now have the following menus available (Mert Tumer, Collabora):
    • Insert ▸ Edit Header and Footer,
    • Tools ▸ Goal Seek,
    • Format ▸ Format Page,
    • Format ▸ Conditional Formatting ▸ Manage
  • Reduce read only toolbar height in Calc (Szymon Kłos, Collabora)

Impress

  • In Impress, users now can use Insert ▸ Header and Footer (Miklos Vajna, Collabora)
  • Impress toolbar now has the button Insert Text Box, which directly inserts at the cursor position (Jan Holesovsky, Collabora)
  • Much improved update of preview in Impress online while there is a change in selection or editing (Ashod Nakashian, Collabora)
  • In Impress, users now have dialogs for formatting characters, paragraphs and the page (Jan Holesovsky, Collabora)
Insert > Chart available in Writer
  • The Insert Chart... toolbar button now also is available in Impress (Jan Holesovsky, Collabora)

Writer

  • Improved displaying of comments, so that those from various places do not overlap (Marco Cecchetti, Collabora)
  • In Writer, users can now add and change watermarks via the dialog (Mert Tümer, Collabora)
Add and edit Watermark in Writer Online
  • In Writer, users can now use the menu (Miklos Vajna, Collabora):
    • Insert ▸ Section
    • Format ▸ Section, and
    • Insert ▸ Table of Contents and Index ▸ Index Entry or .... ▸ Bibliography Entry
  • The Insert Chart… toolbar button now also is available in Writer (Jan Holesovsky, Collabora)
Insert Charts in Writer

Localization

Incorporation of other languages

Improvements to proofing tools and language support

see details on the changes: [1]

  • Afrikaans. The spelling dictionary was updated.
  • Breton. The spelling dictionary was updated.
  • Danish. The spelling dictionary was updated.
  • English (GB). The spelling dictionary was updated.
  • Galician. The spelling dictionary was updated.
  • Serbian. The spelling dictionary was updated.
  • Slovenian. The thesaurus was updated.
  • Spanish. The spelling dictionary was updated.
  • Thai. The spelling dictionary was updated.

Feature removal / deprecation

Java

Support for Java 5 has been removed. Java 6 is now the oldest supported version. (Samuel Mehrbrodt, CIB)

General

GStreamer 0.10 deprecation

Support for GStreamer 0.10 is deprecated and will no longer be present in the subsequent LibreOffice version 6.4 (commit 6b911ae9eb9484bebbdc1323210020486f5ef33f). GStreamer 1.0 continues to be supported.

GUI

KDE4 VCL plugin

KDE4 is out of maintenance upstream since November 2014. LibreOffice’s KDE4 VCL plugin has been removed and binaries provided by TDF have switched to KDE5 as the official backend. commit 410bf59de02192c2daf1158b9de76ec0ebab4c56

GTK+2 VCL plugin

The GTK+2 VCL backend is deprecated and will be removed in the next version.

Personalization

Firefox Personas search & apply functionality has been removed from the personalization dialog (Tools ▸ Options ▸ LibreOffice ▸ Personalization) as per the ESC & Design Team decisions, after major changes on the Mozilla side, which made it impossible to use their legacy API and the themes data for us. The default personas are unaffected, and still functional. Future improvements and more features are planned by the Design Team, thanks to now having a clean slate, without the burden of chasing an external API. Firefox Persona themes are dead; long live the LibreOffice Themes! :) tdf#123831 (Muhammet Kara, Collabora)

Please beware that although users may continue using their already installed personas as long as they don’t switch to a default persona; once a default persona is applied, there is no way to go back to the custom theme via normal means.

Platform Compatibility

Mac

  • Statusbar shows Insert in normal mode on macOS (additional to Overwrite) to draw attention to the context menu tdf#107918 (Heiko Tietze)

Windows

Linux

KDE 5 + Qt5

KDE5/Qt5 VCL plugin received substantial improvement since its first release in LibreOffice 6.2, including but not limited to:

(Jan-Marek Glogowski, Katarina Behrens (CIB), Michael Weghorn (LHM), Aleksei Nikiforov (BaseAlt), Michael Stahl (CIB))

The full list of KDE5 bugs fixed in 6.3 can be found here. Further bugs and missing features are tracked via the KDE meta bug tdf#102495.

32-bit builds removals

Binary Linux x86 (32-bit) releases will be demoted. There will be no Linux x86 builds produced by TDF after 6.2. This does not mean that Linux x86 compatibility will be removed. If you need a 32 bit build, please have a look at your distribution.

API changes

UNO API changes

  • Registering a XMouseListener/XKeyListener to a XWindow will now submit mouse/key events even if technically the events happened in a widget inside that window. - this has been reverted in LibreOffice 6.3.4 due to various regressions (see tdf#127921) (Samuel Mehrbrodt, CIB) tdf#122920

UNO API additions

Configuration changes

SDK changes

Android Viewer

New Features