Notes de publication de LibreOffice 6.3

From The Document Foundation Wiki
Jump to: navigation, search
This page is a translated version of the page ReleaseNotes/6.3 and the translation is 4% complete.

Outdated translations are marked like this.

Warning: Display title "LibreOffice 6.3: Release Notes" overrides earlier display title "Notes de publication de LibreOffice 6.3".

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎日本語 • ‎português do Brasil • ‎русский • ‎slovenščina • ‎中文(中国大陆)‎
BHS large 6.3beta1.png

À propos de cette page

Writer

  • La listes des exceptions à la fonction "COrriger la 2e majuscule en DÉbut de mot" a été étendue pour être également prise en compte lors du changement de casse dans les fonctions "Majuscule en début de phrase" et "Corriger l'usage accidentel de la touche verrouillage MAJ". Ceci permet d'éviter l'auto-capitalisation dans des mots comme ARNm, iPhone, fMRI. Cela a été renommé en "Mots avec DEUX MAJUSCULES INITIALES ou petites capitales iNITIALES 121779}. (Mike Kaganski - Collabora).
  • Ajout de la commande UNO .uno:TableCellBackgroundColor pour permettre le paramétrage de couleur d'arrière-plan d'une ou plusieurs cellules de tableau sélectionnées tdf#82504 (Jim Raykowski).
  • Ajout au navigateur d'un bouton "Envoyer plan vers presse-papiers" -> menu contextuel(clic droit sur "Titres") tdf#123395 (Wenzhe Pei).
  • Les champs de saisie de variables Insertion ▸ Champ ▸ Autres champs... ▸ Variables ▸ Champ de saisie peuvent désormais être modifiés "en ligne", comme c'est déjà possible pour la fonction champ de saisie Insertion ▸ Champ ▸ Autres champs... ▸ Fonctions ▸ Champ de saisie tdf#123968 (Michael Stahl, CIB).
  • La mise à jour des Index/Table de matières peut désormais être annulée/rétablieet n'efface plus la pile des actions annulablestdf#38703 (Michael Stahl, CIB).
  • Amélioration de la copie de Calc dans les tableaux Writer : seules les cellules visibles d'un filtrage sont copiées-collées tdf#124646 (László Németh, NISZ)

Interoperable text-based form controls

  • Optional Forms menu layout, similar to Microsoft Office (Tamás Zolnai, Collabora)
  • Implement GUI for legacy form controls (Tamás Zolnai, Collabora)

See also: Form controls in LibreOffice

Open/Save Performance

  • Improve performance of bookmarks. Export time is 1.5 times faster tdf#117066 (Noel Grandin, Collabora)
  • Improve performance of large tables. tdf#84635 (Noel Grandin, Collabora)
  • Improve performance of embedded fonts. tdf#69060 (Mike Kaganski, Collabora)
  • Improve perfomance for some ODT files tdf#63640 (Noel Grandin, Collabora)

Calc

  • Added UNO API to let cell anchored graphics resize with the cell (Samuel Mehrbrodt, CIB) tdf#124329
  • Added russian rouble new format to money formats. It will show sign (U+20BD) instead руб. (Eike Rathke, Red Hat) tdf#96711
  • Added new drop-down widget into formula bar instead old tool Sum (Gagandeep Singh) tdf#120697
New drop-down widget in formula bar
  • User can disable the extra dialog for search results. For activate of this dialog use option Show summary of replaced cells in dialog Tools > Options > Calc > General > Input Settings tdf#87965 (Heiko Tietze)
Search results
  • Added a new checkbox in Data ▸ Statistics ▸ Moving Average dialog that allows trimming of the input range to the actual data content before computing moving-average. This checkbox is enabled by default. Also fixed the underlying performance problem even for the case when this checkbox is disabled (Dennis Francis, Collabora) tdf#99938.
Moving Average dialog with the new "trim input range" checkbox.
  • The auto-filter popup no longer flickers on Windows without OpenGL tdf#101086 (Miklos Vajna, Collabora)

Rework Data -> Statistics -> Sampling dialog

All work was made by Eike Rathke commit

  • Add "With replacement" checkbutton
    • checked: WR (with replacement, put back after draw), larger sample size than population size possible
      • mutually exclusive with "Keep order"
    • unchecked: WOR (without replacement, do not put back after draw), sample size limited to population size
      • automatically unchecked for "Periodic" samples
  • Add "Keep order" checkbutton
    • checked: samples are drawn in order of population data
      • WOR method mutually exclusive with "With replacement"
      • automatically checked for "Periodic" samples
    • unchecked: samples are drawn in random order
  • Limit "Sample size" and "Period" input fields to size of population for all WOR methods
    • when limiting, increment "Sample size" and "Period" up to their last known value when enlargening the population size

Previously, for "Periodic" samples the "Period" field was never limited, which for populations of smaller size makes no sense.

The new recent implementation for "Random" without "Keep order" and without "With replacement" set (WOR) strictly needs "Sample size" limited to population size.

New spreadsheet functions

FOURIER() function

FOURIER(Array, GroupedByColumns, Inverse, Polar, MinimumMagnitude) is a matrix formula that computes discrete Fourier transform [DFT] of an input array (first argument) using a couple of Fast Fourier Transform algorithms. All features of this formula will also be available graphically via the dialog Data ▸ Statistics ▸ Fourier analysis tdf#74664 blog (Dennis Francis, Collabora)

The data in input array(first argument) can be:

  • grouped by columns (needs to be indicated by flag GroupedByColumns = TRUE). In this case the array can contain 1 or 2 columns, where the first column contains the real part of input sequence and second column if present contains the imaginary part of the input sequence. If there is only 1 column, the input sequence is treated as purely real.
  • grouped by rows (needs to be indicated by flag GroupedByColumns = FALSE). In this case the array can contain 1 or 2 rows, where the first row contains the real part of input sequence and second row if present contains the imaginary part of the input sequence. If there is only 1 row, the input sequence is treated as purely real.

The third argument "Inverse" is a boolean flag to indicate whether an inverse DFT needs to be computed. This argument is optional and the default value is FALSE.

The fourth argument Polar is a boolean flag to indicate whether the final output needs to be in polar coordinates. This argument is optional and the default value is FALSE.

The result of DFT consists of two columns - first column contains the real parts (or the magnitudes if Polar=TRUE) and second column contains the imaginary parts (or the phases if Polar=TRUE).

There is a 5th optional parameter, MinimumMagnitude. This parameter is used only if Polar=TRUE. All frequency components with magnitude less than MinimumMagnitude will be suppressed with a zero magnitude-phase entry. This is very useful when looking at the magnitude-phase spectrum of a signal because there is always some very tiny amount of rounding error when doing FFT algorithms and results in incorrect non-zero phase for non-existent frequencies. By providing a suitable value to this parameter, these non-existent frequency components can be suppressed. By default the value of this 5th parameter is 0.0, so *no* suppression is done by default.

Fourier Analysis Tool in action

Performance

  • Speed-up loading of XLSX files. tdf#121052 tdf#67629 tdf#85482 (Noel Grandin, Collabora)
  • Speed-up loading of ODS files. tdf#120445 (Noel Grandin, Collabora)
  • Speed-up loading and rendering of Calc files (Serge Krot, CIB) tdf#121052
  • Speed-up saving files to XLS format. tdf#85470 (Noel Grandin, Collabora)

Changed spreadsheet functions

Impress & Draw

  • May now drag'n'drop multiple Impress animations to reorder them. (Brian Fraser) commit
  • Introduce an expert option 'WriteLayerStateAsConfigItem' with default value 'true'. If you set it to 'false', the visible/printable/locked state of layers are only written ODF conform to part styles.xml, otherwise to settings.xml in addition. You might need the option 'false' to avoid inconsistency in case you manipulate layers via macro. (Regina Henschel) commit
  • OOXML preset shapes as used by PowerPoint or SoftMaker had some glitches in handle-movement, when you tried to alter the shapes in LibreOffice. The shape outline moved in opposite direction of the handle movement, or the handle jumped to a new location, when you touched it, or the handle was not movable at all. That is fixed for most shapes now.(Regina Henschel, tdf#115813, tdf#125126, tdf#125181, tdf#125445)
  • Various improvements to the import of SmartArt from PPTX files Blog post 1 Blog post 2 blog post 3 blog post 4 (Miklos Vajna, Collabora)

Base

Firebird Migration Assistant, previously available only in experimental mode, will prompt users to migrate their Base HSQLdb embedded files by default.

Includes 13 resolved issues, including:

  • 5 for Firebird sdbc support
  • 2 for MySQL/Mariadb support
  • 1 dBase file format support
  • 2 general UI enhancement

Chart

  • Implement feature to disable legend entry for series (Markus Mohrhard) tdf#51671
  • Add palette selection to options charts default colors (Jim Raykowski) tdf#105225

Math

BASIC

Core / General

  • LibreOffice TWAIN module on Windows was reimplemented as a separate 32-bit shim executable (twain32shim.exe). This allows both 32-bit and 64-bit LibreOffice to use 32-bit TWAIN Windows component. Now finally LibreOffice x64 for Windows is able to use scanner (tdf#114635 - Mike Kaganski, Collabora).
  • The number of saved searches in the Find & Replace dialog can be adjusted per expert configuration Tools ▸ Options ▸ LibreOffice ▸ Advanced org::openoffice::Office::Common::Misc::FindReplaceRememberedSearches tdf#122322 (Heiko Tietze)
  • New command .uno:InsertNarrowNobreakSpace introduced bound to Shift+Alt+Space that inserts a non-breakable narrow space (U+202F) tdf#121596 (Heiko Tietze)
  • Now, like other controls for example the tree control, it is be possible to create and change properties of UNO grid control and UNO Hyperlink control within the Dialog-Editor tdf#53524,i#119731 (Shubham Goyal - Samuel Mehrbrodt, CIB).
  • Tip-Of-The-Day dialog shows useful information once per day on startup tdf#124238 (Heiko Tietze)
Tip of the Day
  • What's-New infobar pointing to the release notes when a new version is started for the first time tdf#69042 (Heiko Tietze)
What's New infobar
  • Sentence selection (triple click) is available for keyboard customization now (no default shortcut assigned) tdf#124552 (Heiko Tietze)
  • If an unmodified template document is opened in an existing window, it will no longer be overwritten by a new document. Instead, a new document will open in a new window tdf#83722 (Katarina Behrens, CIB)

New Feature: Redaction

Now it is possible to redact your documents with LibreOffice to remove/hide sensitive information. blog post (Muhammet Kara, Collabora)

commit 1 commit 2 commit 3 commit 4 commit 5 commit 6 commit 7 commit 8 commit 9 commit 10 commit 11 commit 12 commit 13 commit 14 commit 15 commit 16 commit 17 commit 18 commit 19 commit 20 commit 21 commit 22 commit 23 commit 24 commit 25 commit 26 commit 27

What?

Redaction in its sanitization sense is the blacking out or deletion of text in a document, or the result of such an effort. It is intended to allow the selective disclosure of information in a document while keeping other parts of the document secret. Typically the result is a document that is suitable for publication or for dissemination to others than the intended audience of the original document. For example, when a document is subpoenaed in a court case, information not specifically relevant to the case at hand is often redacted. Redaction in Wikipedia

Although there are some proprietary software applications in the market for this purpose, they have their own limitations like lack of support for open/libre document formats. Thanks to LibreOffice's great support for various file formats, and our recent work on implementing this new feature on top of it, it is now possible to redact most of your documents without leaving the comfort of your favourite office suite.

How?

  • Open your document in LibreOffice
  • Click (Tools ▸ Redact) from the main menu, and wait for your document to be prepared for redaction (converted to an internal meta-format, and transferred to Draw)
  • Do the redaction by using the "Rectangle Redaction", and the "Freeform Redaction" tools on the "Redaction Toolbar".
  • Save & share the in-redaction copies of the document with peers either in the modifiable (odg) or the verbatim (pdf) format at your option
  • Once you are ready to finalize the redaction, click the desired option on the "Redacted Export" tool on the Redaction toolbar

Some Notes:

  • As a result, you will have a pixellized version of the redacted document in PDF. There will be no selectable text in it, and the redacted content will be non-existent.
  • During redaction, the redaction shapes will be transparent and in grey so that the user can see what they are redacting.
The Redaction Toolbar
  • There are currently 4 tools on the Redaction toolbar (from left to right): Rectangle Redaction, Freeform Redaction, Redacted Export, Direct Export to PDF
  • The Rectangle Redaction tool allows the user to mark the content for redaction by drawing transparent rectangles covering the content
  • The Freeform Redaction tool allows the user to mark the content for redaction by drawing freeform lines/polygons covering the content
  • The "Redacted Export" button box has two options: "Redacted Export (Black)" and "Redacted Export (White)". When clicked, it will finalize your document (by converting the transparent grey redaction shapes to opaque black or white shapes), and export as a pixellized PDF file. The "White" option might be preferred to save toner while printing.
  • The Direct Export to PDF button allows the user to take an in-redaction copy of the document in PDF to share as a verbatim copy for review

LibreOffice Help

  • Help pages in Python Macro programming (Alain Romedenne, Olivier Hallot)
  • More pages on undocumented BASIC objects and functions (Alain Romedenne, Olivier Hallot)
  • Python and BASIC code fragments better rendered in Help pages (Olivier Hallot)

Bascode rendering.png

  • Python and Basic code fragments can now be copied to clipboard on a mouse click for later use - tdf#122548 (Olivier Hallot)
  • Extension of the XML dictionary (DTD) to simplify markup for Help pages (Olivier Hallot)
  • The Online Help Editor (Olivier Hallot, Mike Saunders)
  • Refactoring of Math icons to SVG (Mark Robbinson)
  • Refactoring of Help file names for Draw (Ilmari Lauhakangas)
  • Code cleanups and typo fixing (Sophia Schröder, Andrea Gelmini)
  • Calc functions CONCAT, TEXTJOIN, IFS, SWITCH documented (Olivier Hallot, Wilfried Donkers)
  • Calc functions now indicates the LibreOffice release of their implementation (Olivier Hallot, Mike Kaganski)

Filters

Improvements of the PDF export filter

  • added support for PDF/A-2 export, switched UI to use that instead of PDF/A-1 tdf#62728 (Thorsten Behrens, CIB)

Improvements of OOXML filters

Improvements of Tagged PDF export

Several enhancements were made to Tagged PDF export in order to improve accessibility of produced documents and PDF standard compliance, in particular:

  • better tagging of bullets and numbered lists
  • export of image title and description (alt text)
  • images on slide/page background are now exported as artifacts, thus not announced by screenreader

This work has been sponsored by Blackboard Ally (Armin Le Grand, Katarina Behrens, CIB)

GUI

General Improvements

  • Now icons of the uno commands with extra parameters are displayed correctly. commit (Muhammet Kara, Collabora)

Classic Toolbars

  • Toolbar More controls was deleted and all tools from this toolbar were moved to toolbar Form Controls. It was made for all modules of LibreOffice. tdf#112411 (Roman Kuznetsov)

Icon Theme

  • Sifr icon theme got a huge update (Andreas Kainz)
  • Karasa Jaga icon theme reworked from 22px*22px size to 24px*24px one. tdf#124808 (Rizal Muttaqin)
To up Karasa Jaga large icons in version 6.2, to down - in version 6.3
  • Karasa Jaga icon theme got SVG (Scalable Vector Graphics) version. tdf#125368 (Rizal Muttaqin)

Dialogs

Sidebar

  • Sidebar width can now be configured via the Office/UI/Sidebar/General/MaximumWidth config option. tdf#124255 (Samuel Mehrbrodt, CIB)
  • Some improvements to handle different widths for sidebar decks commit 1 commit 2 (Samuel Mehrbrodt, CIB)
  • Changed Bullet style's names in Style section of Writer Sidebar tdf#124471 (Roman Kuznetsov)
Changed Bullet style's names in Style section of Sidebar. Before - to left, after - to right

Calc/Draw tabs

  • Calc and Draw tabs were changed for more visible and usability tdf#124572 (Tomaž Vajngerl, Collabora)
To left Calc tabs in version 6.2, to right - in version 6.3
To left Draw tabs in version 6.2, to right - in version 6.3

Calc Formala bar

  • Drop-down control in Calc Formula bar was reworked for solve some visual problems tdf#101443 (Thorsten Wagner)
On top - before, on bottom - after

Online

Localization

Incorporation of other languages

Feature removal / deprecation

Java

Support for Java 5 has been removed. Java 6 is now the oldest supported version. (Samuel Mehrbrodt, CIB)

General

GUI

KDE4 VCL plugin

KDE4 is out of maintenance upstream since November 2014. LibreOffice's KDE4 VCL plugin has been removed and binaries provided by TDF have switched to KDE5 as the official backend. commit

Personalization

Firefox Personas search & apply functionality has been removed from the personalization dialog (Tools ▸ Options ▸ LibreOffice ▸ Personalization) as per the ESC & Design Team decisions, after major changes on the Mozilla side, which made it impossible to use their API and the themes data for us. The default personas are unaffected, and still functional. Future improvements and more features are planned by the Design Team, thanks to now having a clean slate, without the burden of chasing an external API. Firefox Themes are dead; long live the LibreOffice Themes! :) tdf#123831 (Muhammet Kara, Collabora)

Please beware that although users may continue using their already installed personas as long as they don't switch to a default persona; once a default persona is applied, there is no way to go back to the custom theme via normal means.

Platform Compatibility

Mac

  • Statusbar shows Insert in normal mode on macOS (additional to Overwrite) to draw attention to the context menu tdf#107918 (Heiko Tietze)

Windows

Linux

KDE 5 + Qt5

KDE5/Qt5 VCL plugin received substantial improvement since its first release in LibreOffice 6.2, including but not limited to:

(Jan-Marek Glogowski, Katarina Behrens (CIB), Michael Weghorn (LHM), Aleksei Nikiforov (BaseAlt), Michael Stahl (CIB))

The full list of KDE5 bugs fixed in 6.3 can be found here. Further bugs and missing features are tracked via the KDE meta bug tdf#102495.

API changes

UNO API changes

  • The range of supported values for a Writer document's com.sun.star.text.ViewSettings property ZoomValue has been reduced from 5–1000 to 20–600. commit
  • Registering a XMouseListener/XKeyListener to a XWindow will now submit mouse/key events even if technically the events happened in a widget inside that window. (Samuel Mehrbrodt, CIB) tdf#122920

Configuration changes

SDK changes

Android Viewer

New Features