Lokalisierung

From The Document Foundation Wiki
Jump to: navigation, search

Allgemeine Hinweise

Unter »Lokalisierung« wird im Projekt LibreOffice die Übersetzung von LibreOffice (LibO) sowie der dazugehörigen Benutzerhandbücher und Webseiten in die jeweilige Landessprache verstanden – auf diesem Wiki also die Übersetzung vom Englischen in das Deutsche.

Helfer sind jederzeit willkommen.

Die Übersetzung umfasst folgende Bestandteile:

Datenbank für korrekte Übersetzungen

Da es immer wieder offene Fragen bzgl. einer korrekten Übersetzung von englischen Begriffen gibt, wurde in diesem Wiki eine Übersicht zu bestimmten Begriffen aufgebaut (s. Datenbank für korrekte Übersetzungen).

Daneben gibt es in Pootle eine spezielle Datenbank, in der für die unmittelbare Übersetzungsarbeit in Pootle für viele englische Begriffe ein deutscher Übersetzungsvorschlag enthalten ist (Link zu libo_general_de.po). Im Gegensatz zu der Datenbank im Wiki enthält die Datenbank von Pootle keine Diskussion oder Erklärungen. Prinzipiell kann die Datei ganz einfach bearbeitet werden:

  • Datei runterladen.
  • Datei bearbeiten:
    • Neuen Begriff anfügen (der Aufbau sollte sich weitgehend aus den existierenden Einträgen erklären).
    • Nicht vegessen, ganz am Ende eine Leerzeile einzufügen.
  • Datei hochladen.
    • Wenn Hochladen nicht funktioniert, überprüfen, ob Datei am Ende eine Leerzeile enthält.

Bitte beachten: die Bearbeitung der po-Datei mit dem Lokalisationsteam abstimmen, d.h. zuvor auf der de-discuss-ML Bescheid geben.

Weitere wichtige Wiki-Seiten zum Thema »Lokalisierung«


Wiki-Seiten für spezielle Übersetzungsprobleme

UI

Hauptmenüpunkt "Datei": Übersetzung von "version" und "revision number"

Hinweis: im allgemeinen (deutschen) Sprachgebrauch wird "Revision" synonym zu "Version" verwendet.

Sachverhalt 1:

  • Einfügen ▸ Feldbefehl ▸ Andere... ▸ Dokumentinfo ▸ Version oder
  • Datei ▸ Eigenschaften... ▸ Allgemein ▸ Version
  • Dieser Sachverhalt nennt die Anzahl derabgespeicherten Versionen eines Dokumentes.
  • Englisches Original: "revision number"
  • Deutschsprachige Übersetzung: "Version"
  • Sonstige Übersetzungsvorschläge: "Dateiversion", "Revisionsnummer", "Bearbeitungszähler", "Revisionsstand", "Revision", "Änderungszähler"

Sachverhalt 2:

  • Datei ▸ Versionen... (bis 14.11.2011)
  • Dieser Sachverhalt listet die unterschiedlichen Versionen eines Dokumentes auf, die in dem Dokumentgespeichert werden.
  • Englisches Original: "Versions..."
  • Deutschsprachige Übersetzung: "~Versionsspeicher" (ab 14.11.2011)
  • Sonstige Übersetzungsvorschläge: "Versionsablage", "Zwischenversionen", "Arbeitskopie", "Version", "gespeicherte Fassung", "Ausführung", "Bearbeitungsstand", "Gespeicherte Revisionen...", "Gespeicherte Dateimodifikationen...", "Gespeicherte Dateiversionen"

Sidebar

Die Sidebar gibt es in Writer, Calc, Draw und Impress, aber nicht in Base und Math und nicht für Charts.

In LO ist "sidebar" ab 5/13 in den daily builds drin bzw. kann unter Tools > Options > LibreOfficeDev > Advanced eingeschaltet werden.

Der Begriff "sidebar" bzw. die dazu gehörigen Begriffe sind schwierig zu übersetzen. Für AOO wurde eine Zusammenschau erstellt (s. http://wiki.openoffice.org/wiki/DE/HilfeUebersetzung_Sidebar) sowie eine "Hilfe" erstellt (s. http://people.apache.org/~regina/SidebarHelpProposal2.odt)

Calc: Problem "Übersetzung von Funktionen"

Stand: 2/13

In den runden Klammern steht die en-US UI-Bezeichnung.

Eine Übersetzung, wie sie in Excel verwendet wird, kann auf der Seite de.excel-translator.de gefunden werden.

Eine Übersicht des originalen Zusammenstellung im MS Excel findet sich unter http://office.microsoft.com/de-de/excel-help/excel-funktionen-alphabetisch-HA102753227.aspx?CTT=1 bzw. in Englisch http://office.microsoft.com/en-us/excel-help/excel-functions-alphabetical-HA102753227.aspx?CTT=3 So wie es aussieht, sind die deutschen Bezeichnungen in der gleichen Reihenfolge wie die englischen, was man natürlich an den Erklärungen überprüfen muss, bevor man es übernimmt.

Tabelle, in der alle Funktionen aufgelistet sind und der Bearbeitungsstand in Pootle dokumentiert wird: File:Calc Excel Funktionen Pootle.ods

Die folgende Tabelle ist nach Meinung von Jochen zu aufwändig (über 450 Funktionen müssen "gepflegt" werden).

englisch deutschsprachig in Excel vorhanden für LO konsentiert (ja/nein) in Pootle überprüft und ggfs. geändert (ja/nein) in terminology-Datei eingetragen (ja/nein)
ACOT ARCCOT ja nein nein nein
ACOTH ARCCOTHYP ja nein nein nein
ARABIC ARABISCH ja nein nein nein
BASE BASIS ja nein nein nein
BINOM.DIST.RANGE (B) BINOM.VERT.BEREICH ja nein nein nein
BITAND BITUND ja
BITLSHIFT BITLVERSCHIEB ja
BITOR BITODER ja
BITRSHIFT BITRVERSCHIEB ja
BITXOR BITXODER ja
COMBINA KOMBINATIONEN2 ja
COT COT ja
COTH COTHYP ja
CSC COSEC ja
CSCH COSECHYP ja
DAYS TAGE ja
DECIMAL DEZIMAL ja
FORMULATEXT (FORMULA) FORMELTEXT (FORMEL) ja
GAMMA GAMMA ja
GAUSS GAUSS ja
IFNA WENNNV ja
IMCOSH IMCOSHYP ja
IMCOT IMCOT ja
IMCSC IMCOSEC ja
IMCSCH IMCOSECHYP ja
IMSEC IMSEC ja
IMSECH IMSECHYP ja
IMSINH IMSINHYP ja
IMTAN IMTAN ja
ISFORMULA ISTFORMEL ja
MUNIT MEINHEIT ja
NUMBERVALUE ZAHLENWERT ja
PDURATION (DURATION) (noch nicht festgelegt) ja
PERMUTATIONA VARIATIONEN2 ja
PHI PHI (oder noch nicht festgelegt) ja
RRI ZSATZINVEST ja
SEC SEC ja
SECH SECHYP ja
SHEET BLATT ja
SHEETS BLÄTTER ja
SKEW.P (SKEWP) SCHIEFE.P (SCHIEFE) ja
UNICHAR UNIZEICHEN ja
UNICODE UNICODE ja
XOR XODER ja

Calc und Writer: Problem "Übersetzung von Grid"

Frontend Kontext/Menü Calc (akutell) Calc (Vorschlag)
UI Extras -> Optionen -> LibreOffice Calc -> Ansicht Gitter Gitter
Hilfe Index "Gitter -> Linien anzeigen" Gitterlinien, Gitter und Tabellengitter ---
Hilfe Index "Raster -> Vorgaben (Writer/Calc) Raster Raster
Frontend Kontext/Menü Writer (akutell) Writer (Vorschlag)
UI Extras -> Optionen -> LibreOffice Writer -> Raster Raster Raster
Hilfe Index "Raster -> Vorgaben (Writer/Calc) Raster Raster

Fraglich richtige These:

  • Immer wenn es um etwas geht, an dem Objekte einrasten könnten, dann heißt es "Raster".
  • Nur die Linien zwischen den Zellen einer Calc-Tabelle heißen "Gitter".
  • Da es "Gitter" nur in Calc gibt, muss es bei den anderen Modulen immer "Raster" heißen.

Offene Fragen:

  • Übersetzung, wo das Segment im Ordner „shared“ liegt und folglich von mehreren Modulen benutzt wird

Impress und Draw: Problem "Folie" und "Seite"

Es ist vorgesehen, im ersten Schritt im Wiki für Impress und Draw getrennt eine Übersicht erstellen, welche Begriffe im Menü und im Kontext ("rechte Maustaste") unserer Meinung nach nicht korrekt sind.

  • Erledigt.

Als zweiter Schritt ist vorgesehen, zu überlegen, ob eine Trennung zwischen "Impress" und "Draw" in Pootle sinnvoll und machbar ist.

  • Erledigt: Konsens, dass eine Trennung zwischen "Impress" und "Draw" in Pootle nicht sinnvoll ist.

Als dritter Schritt muss die Lokalisation im UI und in der Hilfe durchgeführt werden.

Als vierter Schritt ist zu überlegen, ob die Reihenfolge der (gleichen) Inhalte der Kontextmenüs im Folien- und Editorbereich vereinheitlicht werden sollen. Dies muss aber international abgestimmt werden.

Einträge, die nicht verändert werden sollten

(Kontext-) Menü Impress (akutell) Impress (Vorschlag) Bemerkungen
  • Handzettel: Inhalt
Seitenzahlbereich Seitenzahlbereich Sollte bleiben, da es den Ausdruck (Papierformat etc.) betrifft.
4820353 (page)
  • Menü: Format
S~eite... S~eite... Sollte bleiben, da es den Ausdruck (Papierformat etc.) betrifft.
4819219 (slide)
  • Kontextmenü: Seite/Folie
Seite e~inrichten... Seite e~inrichten... Sollte bleiben, da es den Ausdruck (Papierformat etc.) betrifft.
4820689 (page) Nur einen Pootle-Eintrag gefunden => Mit Draw gekoppelt!?

Einträge mit Fehlerkorrektur

(Kontext-) Menü Impress (akutell) Impress (Vorschlag) Bemerkungen
  • Gliederungsansicht-Kontextmenü:
~Zeichnungsansicht Normalansicht
  • Dieser Eintrag benötigt in Pootle einen neuen Symlink!
  • Welcher der Pootle-Einträge noch nicht klar!
  • Änderung wäre OK!
  • Ansicht "Normal" gibt es auch in Draw!?

Einträge, die in Impress verändert werden sollten

(Kontext-) Menü Impress (akutell) Impress (Vorschlag) Bemerkungen
  • Menü: Einfügen
S~eite Folie
  • Diese Einträge benötigen in Pootle neue Symlinks!
  • Änderung wäre OK!
4819222 (slide)
  • Nur einen Pootle-Eintrag gefunden => Mit Draw gekoppelt!?
  • Menü: Einfügen
Seite d~uplizieren Folie d~uplizieren
  • Änderung wäre OK!
4801888 (slide)
  • Nur einen Pootle-Eintrag gefunden => Mit Draw gekoppelt!?
  • (Es gibt noch einen zweiten Pootle-Eintrag: 4819224 (slide) "Folie d~uplizieren" aber keinen mehr mit "Seite d~uplizieren" ==> Bug: falsche Einbindung der Strings in LibreOffice???)
  • Menü: Einfügen -> Feldbefehl
~Seitennummer Foliennummer
  • Diese Einträge benötigen in Pootle neue Symlinks!
  • Änderung wäre OK!
  • Die Zuordnung der Pootle-Einträge noch nicht klar (einer gehört vermutlich zu Draw)!
  • Menü: Einfügen -> Feldbefehl
~Gesamtzahl der Seiten ~Gesamtzahl der Folien
  • Änderung wäre OK!
4801970 (page)
  • Nur einen Pootle-Eintrag gefunden => Mit Draw gekoppelt!?
  • Menü: Extras -> Optionen... -> LibreOffice Impress/Draw -> Drucken
Seiten~name Folien~name
  • Änderung wäre OK!
  • Die Zuordnung der Pootle-Einträge noch nicht klar (einer gehört vermutlich zu Draw)!
  • Menü: Extras -> Optionen... -> LibreOffice Impress/Draw -> Drucken
Seiten ~kacheln Folien ~kacheln
  • Änderung wäre OK!
4820522 (page)
  • Nur einen Pootle-Eintrag gefunden => Problem: in Pootle gekoppelt!?
  • Kontextmenü: Seite/Folie umbenennen: Dialogtitel
  • Seiten-/Folienbereich-Kontextmenü: Seite/Folie umbenennen: Dialogtitel
Seite umbenennen Folie umbenennen
  • Änderung wäre OK!
  • Die Zuordnung der Pootle-Einträge noch nicht klar / Es fehlen noch weitere!

Noch nicht zugeordnete, zusätzliche Einträge in Pootle

Die folgende Liste enthält alle ausfindig gemachten Pootle-Einträge, die das englische Wort "slide" (Folie) mit "Seite" im Deutschen übersetzen und nicht von mir einem Menü- oder anderen Eintrag zugeordnet werden konnten. Sie umfasst nur die UI-Strings, nicht die Hilfe, die nach einer eventuellen Änderung ebenfalls noch durchgesehen werden müsste.

Falls jemand eine Ahnung hat, hinter welchem Menü- oder anderen Eintrag sich einer der unten stehenden Strings versteckt, so notiert es einfach mit möglichst präziser Angabe hinter dem Eintrag oder postet es auf der discuss-ML, ich sortiere das dann an der entsprechenden Stelle und mit allen erforderlichen Informationen in obige Liste ein. ()

  • Folien ~aus Gliederung 4819226
  • Seiten ~aus Gliederung 4801891
  • Seite direkt einfügen 4801944
  • Seite/Ebene 4802242
  • Seiten verschieben 4817826
  • Folienwechsel 4801706
  • Seitenwechsel 4817924
  • Folie einfügen 4820640
  • Seite einfügen 4819501
  • Der Seitenname ist schon vorhanden oder ungültig.Geben Sie bitte einen anderen Namen ein 4819708
  • Seiten löschen 4819780
  • Seiten löschen 4819725
  • Seiten einfügen 4819728
  • Seiten erzeugen 4819766
  • Diese Aktion löscht die Liste der Arbeitsschritte, die\n
    rückgängig gemacht werden können. Bisher gemachte\n
    Änderungen am Dokument bleiben erhalten, können jedoch nicht\n
    mehr rückgängig gemacht werden. Wollen Sie fortfahren\n
    und die neue Seitenvorlage zuweisen? 4819773
  • Sollen die Grafikobjekte an das neue Seitenformat angepasst werden? 4819814
  • Sprung zur vorhergehenden Seite 4819854
  • Sprung zur nächsten Seite 4819857
  • Sprung zur ersten Seite 4819859
  • Sprung zur letzten Seite 4819861
  • Seite / Objekt 4819908
  • Seitenvorlage laden 4819946
  • Seite erweitern 4820052
  • Inhaltsverzeichnis-Seite 4820056
  • Seiten/Objekte einfügen 4819776
  • Erste Seite 4820574
  • vorherige Seite 4820576
  • Nächste Seite 4820578
  • Letzte Seite 4820585
  • Seite 4819750
  • Se~ite 4819197
  • ~Übersichtsseite 4819227
  • Seite einfügen 4819501
  • Sprung zu Seite oder Objekt 4819864
  • Hintergrundeinstellungen für alle Seiten? 4820316


Draw

Problem: Übersetzung von "layout", "controls" und "measurelines"

Zusammenfassung (Stand: 04.05.2013; Jochen):

1) Lokalisierung:
In der 4er-Reihe von LO ist ist bis 4.0.2 der englische Begriff "Controls" nicht lokalisiert.
In 4.0.3 wird die Lokalisierung wahrscheinlich umgesetzt sein (ich habe mir allerdings LO 4.0.3 RC2 nicht runtergeladen).

2) Begriffe:
Es besteht eine mehrheitliche Meinung auf der de-discuss-ML, dass die deutschsprachigen Begriffe "Layout", "Steuerelemente" und "Maßlinien" angemessen sind und nicht geändert werden sollen.
Diese Begriffe können vom User nicht geändert werden - im Gegensatz zu manuell eingefügten "Ebenen-Reitern".

3) Makros:
Es besteht für den Begriff "Maßlinien" ein Problem beim Einbau in Makros.
Eine detailierte Aufstellung/Analyse, wann welcher englischer und deutschsprachige Begriff der Begriffe "Layout", "Steuerelemente" und "Maßlinien" bei Makros verwendet kann, fehlt noch und könnte im Rahmen des QA-Gedankens (von einem "Draw-Kenner") noch erstellt werden.

Problem: Übersetzung von "Folie" und "Seite"

s. Kapitel Impress und Draw: Problem "Folie" und "Seite"

Pootle

Mittels "Pootle" werden die Programmoberfläche (UI) und die im Programm integrierten Hilfedateien übersetzt. Weitere Informationen zu Pootle findest Du auf der Wiki-Seite "Pootle".